Bug 170310 - i810 can not display 1600x1200 on a capable graphics card and monitor
i810 can not display 1600x1200 on a capable graphics card and monitor
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11 (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-10 13:31 EDT by Josep Puigdemont
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-14 16:13:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josep Puigdemont 2005-10-10 13:31:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050921 Red Hat/1.0.7-1.4.1 Firefox/1.0.7

Description of problem:
The latest upgrades of xorg-x11 probably introduced a bug in i810 driver that doesn't allow it to display 1600x1200 on a monitor capable of it, although the previous version had no problem displaying such resolution.


Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-1.EL.13.20

How reproducible:
Always

Steps to Reproduce:
1. Update the system with up2date to the latest packages
2. restart X server

(provided you have the hardware specified below)

Actual Results:  The display resolution is 1280x1024 (virtual 1600x1200).


Expected Results:  Real display resolution of 1600x1200.


Additional info:

This is a Dell optiplex GX280 computer.

The graphics card is a i915GL:
# lspci -vd 8086:2582
00:02.0 VGA compatible controller: Intel Corporation 82915G/GV/910GL Express Chipset Family Graphics Controller (rev 04) (prog-if 00 [VGA])
        Subsystem: Dell: Unknown device 0179
        Flags: bus master, fast devsel, latency 0, IRQ 169
        Memory at dff00000 (32-bit, non-prefetchable) [size=512K]
        I/O ports at e898 [size=8]
        Memory at c0000000 (32-bit, prefetchable) [size=256M]
        Memory at dfec0000 (32-bit, non-prefetchable) [size=256K]
        Capabilities: [d0] Power Management version 2
# lspci -vd 8086:2782
00:02.1 Display controller: Intel Corporation 82915G Express Chipset Family Graphics Controller (rev 04)
        Subsystem: Dell: Unknown device 0179
        Flags: bus master, fast devsel, latency 0
        Memory at dff80000 (32-bit, non-prefetchable) [size=512K]
        Capabilities: [d0] Power Management version 2

Monitor is a Dell 2001FP (Digital)
Comment 1 Trond H. Amundsen 2005-10-11 10:04:20 EDT
Just a me too.. I get the exact same result with this hardware. We have lots of
standard Dell GX280s with the 2001FP monitor, so this can potentially hit us
hard, whenever users do the occasional X11 restart. A large-scale downgrade of
X11 is unappealing at the best... Any chance that this bug will be fixed very soon?
Comment 2 Josep Puigdemont 2005-10-11 10:13:13 EDT
Making this "ModeLine" entry in /etc/X11/xorg.conf, make it work for me:

ModeLine     "1600x1200" 160.00 1600 1664 1856 2160 1200 1201 1204 1250


The whole "Monitor" section is here:

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Dell 2001FP (Digital)"
        DisplaySize  408 306
        HorizSync    31.0 - 80.0
        VertRefresh  56.0 - 76.0
        Option       "dpms"
        ModeLine     "1600x1200" 160.00 1600 1664 1856 2160 1200 1201 1204 1250
EndSection


The rest of the file I left it as it was.

By the way, this must be sort of a hack, since the old configuration could work
without this "ModeLine" setting. I have some other GX280 around without the
upgrades and the only difference in the xorg.conf file is that ModeLine.

References:
http://wiki.x.org/wiki/FAQVideoModes
https://www.redhat.com/archives/rhn-users/2005-October/msg00051.html
Comment 3 Trond H. Amundsen 2005-10-11 10:30:02 EDT
Thanks, Josep. You saved the day :) Now this is suddenly not that urgent for me
anymore, but it is still a bug that should be fixed.
Comment 4 David Mansfield 2005-12-20 10:36:08 EST
me too. same monitor (dell 2001FP). 

above fix worked for me BUT i had to reboot instead of just restarting X
Comment 5 Mike A. Harris 2006-03-07 23:31:39 EST
I believe this is the same problem that's been reported many many times in
bugzilla in the past, in which the Dell 2001FP returns incorrect EDID data
to the driver during DDC probing, resulting in lower bandwidth being reported
than the display is capable of.  Subsequently the driver calculates some modes
as being invalid with the lower frequencies, and the modes are trimmed from the
mode pool.

Users have reported this was not the case in earlier driver releases, and
the reason this is the case in this driver release is that previously DDC
was disabled by default, however it is now enabled by default in the current
driver by the choice of the upstream i810 driver maintainer.

Please try using:  Option "noddc"
in the device section of xorg.conf and restarting to see if the display now
works as expected, and report back your results.

If the problem still exists, please attach to this report your xorg.conf and
X server log from without the noddc option, and then with the noddc option
so we can compare the modelist pruning results, etc.

I'm pretty sure this is just a duplicate bug report however, and the core
of the problem is the buggy Dell flat panel EDID data.  ie: Hardware bug.
Comment 6 Josep Puigdemont 2006-03-14 04:49:34 EST
Hi,

Sorry for it took such a long time to test your suggestion.
I removed the lines

DisplaySize  408 306
ModeLine     "1600x1200" 160.00 1600 1664 1856 2160 1200 1201 1204 1250

and added

Option "noddc"

And this does the trick, it works as it did before.

I'm sorry to have bothered you with a hardware bug, I guess you can close the bug.

Thanks.
Comment 7 Mike A. Harris 2006-03-14 16:13:13 EST
Thanks for the update.

Changing status to "NOTABUG"

Note You need to log in before you can comment on or make changes to this bug.