This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 17032 - core dump accessing glXGetCurrentContext (Mesa 3.3-5)
core dump accessing glXGetCurrentContext (Mesa 3.3-5)
Status: CLOSED DUPLICATE of bug 18867
Product: Red Hat Raw Hide
Classification: Retired
Component: Mesa (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-28 09:40 EDT by Bernhard Ege
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-28 09:40:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernhard Ege 2000-08-28 09:40:51 EDT
This little proggy creates a core dump (when it shouldn't):

#include <GL/gl.h>

int main() {

  glXGetCurrentContext();

  return 0;
}

compile: gcc -o glx glx.c  -lGL

This is what gdb says:

#0  0x4013f6d0 in glXGetCurrentContext () from /usr/lib/libGL.so.1

regards,

Bernhard Ege
Comment 1 Bernhard Rosenkraenzer 2000-10-11 08:41:18 EDT

*** This bug has been marked as a duplicate of 18867 ***

Note You need to log in before you can comment on or make changes to this bug.