Bug 1703397 - Trying to create container results in 500 error
Summary: Trying to create container results in 500 error
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Container Management
Version: 6.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: 6.5.2
Assignee: Marek Hulan
QA Contact: Mirek Długosz
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-26 10:36 UTC by Mirek Długosz
Modified: 2019-10-30 17:02 UTC (History)
8 users (show)

Fixed In Version: tfm-rubygem-foreman_docker-4.1.0.1-1
Doc Type: Known Issue
Doc Text:
This is a known issue expected to be fixed.
Clone Of:
Environment:
Last Closed: 2019-08-06 14:37:33 UTC
Target Upstream Version:


Attachments (Terms of Use)
foreman.log file (47.14 KB, text/plain)
2019-04-26 10:36 UTC, Mirek Długosz
no flags Details
Hotfix (220.79 KB, application/x-rpm)
2019-05-14 21:32 UTC, Christian Marineau
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 26740 0 Normal Closed V2 tag listing does not follow redirects 2021-01-28 18:41:02 UTC
Red Hat Product Errata RHBA-2019:2363 0 None None None 2019-08-06 14:37:43 UTC

Description Mirek Długosz 2019-04-26 10:36:12 UTC
Created attachment 1558986 [details]
foreman.log file

Trying to create docker container results in 500 error.

Steps to reproduce:
1. Install and start docker on Satellite machine
2. hammer -v -u admin -p changeme --output=csv compute-resource create --name="localdocker" --organization-ids="1" --provider="Docker" --url="unix:///var/run/docker.sock"
3. hammer -v -u admin -p changeme --output=csv docker registry create --name="externalregistry" --url="https://registry.access.redhat.com"
4. hammer -v -u admin -p changeme --output=csv docker container create --command="top" --compute-resource-id="6" --name="samplecontainer" --organization-ids="1" --registry-id="4" --repository-name="rhel" --tag="latest"

Actual results:
Could not create the container:
  Expected([200, 201, 202, 203, 204, 304]) <=> Actual(302 Found)


Excerpt from foreman production.log file is attached.

According to reportportal, this first occurred on snap 19. Sorry it took so long to notice and report it.


Version:
Satellite 6.5 snap 25
satellite-6.5.0-11.el7sat.noarch
foreman-1.20.1.34-1.el7sat.noarch
tfm-rubygem-katello-3.10.0.46-1.el7sat.noarch
pulp-server-2.18.1.1-1.el7sat.noarch
tfm-rubygem-foreman_docker-4.1.0-2.el7sat.noarch

Comment 2 Sachin Ghai 2019-04-30 12:58:47 UTC
Is it a regression Mirek ?

Comment 6 Marek Hulan 2019-05-03 14:37:01 UTC
The fix is available

Comment 7 Bryan Kearney 2019-05-03 16:03:55 UTC
Upstream bug assigned to mhulan@redhat.com

Comment 8 Bryan Kearney 2019-05-03 16:03:56 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue https://projects.theforeman.org/issues/26740 has been resolved.

Comment 10 Christian Marineau 2019-05-14 21:32:40 UTC
Created attachment 1568704 [details]
Hotfix

Comment 14 Mirek Długosz 2019-07-12 11:27:59 UTC
Steps to reproduce from initial message no longer result in error message. Container can be created and can be later searched for, listed and inspected.

Tested on:
Tested on:
Satellite 6.5.2 snap 1
pulp-server-2.18.1.1-1.el7sat.noarch
foreman-1.20.1.35-1.el7sat.noarch
tfm-rubygem-katello-3.10.0.53-1.el7sat.noarch
satellite-6.5.2-1.el7sat.noarch
tfm-rubygem-foreman_docker-4.1.0.1-1.el7sat.noarch

Comment 16 errata-xmlrpc 2019-08-06 14:37:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2363


Note You need to log in before you can comment on or make changes to this bug.