Bug 170343 - RFE: create lucene-devel
RFE: create lucene-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lucene (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Vadim Nasardinov
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-10 16:27 EDT by Andrew Overholt
Modified: 2008-08-02 19:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-02 12:12:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lucene.spec.patch (2.28 KB, patch)
2005-11-11 18:47 EST, Vadim Nasardinov
no flags Details | Diff

  None (edit)
Description Andrew Overholt 2005-10-10 16:27:01 EDT
Description of problem:
Eclipse contains lucene-1.4.3-src.zip and aot-compile-rpm's smarts pick up
classes in there and compile them.  It would be nice if we had a lucene-devel
package which contains the src zip (for use with Eclipse ... just like the
Eclipse *-devel packages).

Version-Release number of selected component (if applicable):
lucene-1.4.3-1jpp_3fc
Comment 1 Fernando Nasser 2005-11-09 14:35:52 EST
Does it need all the classes or just a subset?
Comment 2 Andrew Overholt 2005-11-10 20:00:12 EST
This is the zip:

http://www.apache.org/dist/jakarta/lucene/lucene-1.4.3-src.zip
Comment 3 Vadim Nasardinov 2005-11-11 18:47:01 EST
Created attachment 120970 [details]
lucene.spec.patch

The contents of the file you mention in comment #2 are identical
to the contents of the 

Source0: http://cvs.apache.org/dist/jakarta/lucene/lucene-1.4.3-src.tar.gz

in lucene/devel/lucene.spec.

So, I added the lucene-devel subpackage which simply ships the
following file:

| $ rpm -qlp lucene-devel-1.4.3-1jpp_8fc.i386.rpm
| /usr/src/lucene/lucene-1.4.3.jar

The file lucene-1.4.3.jar is constructed by untarring
lucene-1.4.3-src.tar.gz and jarring it up.  Once you have this, you
can change eclipse.spec to require "lucene-devel" and symlink
/usr/src/lucene/lucene-1.4.3.jar to
plugins/org.apache.lucene/lucene-1.4.3-src.zip or some such.

As far as I understand, the only reason Eclipse needs this zip file is
so that it can step into Lucene in the debugger.  If that really is
the only purpose of having this file, then it should probably be
cleaned up a little bit.  In addition to .java files, it has some
other stuff that Eclipse probably doesn't care about:

| $ for ff in $(find lucene-1.4.3 -type f); do echo ${ff##*.}; done | sort |
uniq
| gif
| htm
| html
| jar
| java
| jhtml
| jj
| jpg
| jsp
| txt
| xml

For example, I doubt we have any real need for junit.jar:

| $ ls -lh lucene-1.4.3/lib/junit-3.8.1.jar
| -rw-r--r--  1 vadim vadim 119K Nov 11 17:32 lucene-1.4.3/lib/junit-3.8.1.jar


Secondly, the whole notion of shipping source as a binary RPM seems to
go against the spirit of the following note in the FC3 Release Notes:

http://fedora.redhat.com/docs/release-notes/fc3/x86/#id850167

   | In order to eliminate the redundancy inherent in providing a
   | separate package for the kernel source code when that source code
   | already exists in the kernel's .src.rpm file, Fedora Core 3 no
   | longer includes the kernel-source package. Users that require
   | access to the kernel sources can find them in the kernel .src.rpm
   | file.

You could argue that the same reasoning applies to lucene-devel.

(Personally, I'm on the opposite side of this particular fence.  I
think it is very convenient to be able to install source files into a
well-known location where debuggers can be pre-configured to look for
it.)


Anyhow, should I apply this patch as is or is there anything that you
want me to change?
Comment 4 Andrew Overholt 2005-11-24 11:00:01 EST
(In reply to comment #3)
> 
> | $ rpm -qlp lucene-devel-1.4.3-1jpp_8fc.i386.rpm
> | /usr/src/lucene/lucene-1.4.3.jar

Awesome.

> As far as I understand, the only reason Eclipse needs this zip file is
> so that it can step into Lucene in the debugger.  If that really is
> the only purpose of having this file, then it should probably be
> cleaned up a little bit.

Yeah, that's correct.  How important is the cleanup in your opinion?

> For example, I doubt we have any real need for junit.jar:
> 
> | $ ls -lh lucene-1.4.3/lib/junit-3.8.1.jar
> | -rw-r--r--  1 vadim vadim 119K Nov 11 17:32 lucene-1.4.3/lib/junit-3.8.1.jar

Yeah, that's something that could easily be removed.

> Anyhow, should I apply this patch as is or is there anything that you
> want me to change?

It's exactly what I need.  If you feel the cleanup is important, I guess that
could block this but perhaps we're better off just making a new bug for that.

Thanks!
Comment 5 Vadim Nasardinov 2005-11-24 20:43:47 EST
Andrew,

I committed the changes a few days ago but couldn't submit a build job
to beehive due to the dist-fc5 lockdown.  I'll retry on Monday.
Comment 6 Vadim Nasardinov 2005-11-28 16:05:18 EST
Andrew,

The build fails on ia64.  I'm afraid I won't have the time to debug this.
Comment 8 Andrew Overholt 2007-01-02 12:12:08 EST
I think this is fixed.  Closing.

Note You need to log in before you can comment on or make changes to this bug.