Bug 170344 - -S option to passwd command not working properly
-S option to passwd command not working properly
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: passwd (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-10 16:43 EDT by Steve Manuel
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: passwd-0.72-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-14 11:25:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Manuel 2005-10-10 16:43:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Description of problem:
Using the '-s' option of passwd in Solaris I get this output:

/u01/data # uname -ar
SunOS 5.9 Generic_118559-08 i86pc i386 i86pc
/u01/data # passwd -s cutr0
cutr0     PS    09/28/05     7    90     7

I get this same output using passwd -S in Ubuntu:

lisbon:$ uname -ar
Linux lisbon 2.6.8.1-2-386 #1 Tue Sep 14 10:30:08 BST 2004 i686 GNU/Linux
lisbon:$ passwd -S jortega
jortega P 02/18/2005 0 99999 7 -1

and this from passwd I built from pwdutils from gnu.org:
[fugue bin]$ sudo ./passwd -S smanuel
smanuel PS 08/24/2005 0 99999 7 -1

and in SuSE I get this:
rappel:~ # passwd -S
root PS 09/27/2005 0 10000 -1 -1

However, from FC4/FC3 and RHEL3/4 I get this:
[smanuel@fugue ~]$ sudo /usr/bin/passwd -S smanuel
Password set, MD5 crypt.




Version-Release number of selected component (if applicable):
passwd-0.69-2

How reproducible:
Always

Steps to Reproduce:
1. run (as root or via sudo) passwd -S <username>
2.
3.
  

Actual Results:  passwd -S returns: 

Password set, MD5 crypt.

Expected Results:  passwd should return the same info as the GNU version of passwd which, among other info, shows the last password change date.

Additional info:

Although a small bug, if you are doing SOX auditing this command is extremely useful. And since the GNU version (and the two other leading linux distros as well as Solaris) return this info, FC/RH should as well.
Comment 1 Tomas Mraz 2005-10-11 03:06:23 EDT
Valid enhancement request.
Comment 2 Tomas Mraz 2006-07-14 11:25:21 EDT
root@perun:~# passwd -S mraz
mraz PS 2006-02-24 0 99999 7 -1 (Password set, MD5 crypt.)

Note You need to log in before you can comment on or make changes to this bug.