Bug 170349 - stap gets Unsupported relocation type errors when trying to probe ext3 module
stap gets Unsupported relocation type errors when trying to probe ext3 module
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: systemtap (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Roland McGrath
Jay Turner
:
Depends On:
Blocks: 168429
  Show dependency treegraph
 
Reported: 2005-10-10 17:27 EDT by Kiersten (Kerri) Anderson
Modified: 2015-01-07 19:10 EST (History)
2 users (show)

See Also:
Fixed In Version: RHEA-2006-0088
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-07 13:43:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kiersten (Kerri) Anderson 2005-10-10 17:27:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041215 Firefox/1.0 Red Hat/1.0-12.EL4

Description of problem:
The RHEL4 U2 kernel packages still have this problem using 2.6.9-22 packages
when trying to use stap.  This one needs to be on the RHEL4U3 Proposed list.  

[root@niobe-02 stap]# rpm -q kernel kernel-debuginfo
kernel-2.6.9-22.EL
kernel-debuginfo-2.6.9-22.EL
[root@niobe-02 stap]# cat ext3.stp

/* ext3.stp
        Collect ext3 statistics on function calls
*/

global  count_ext3_statfs

probe module("ext3*").function("*")
{
        ++count_ext3_statfs
}

probe begin { log("starting probe") }

probe end
{
        log("ending probe")
        log("ext3_statfs() called "
         . string(count_ext3_statfs)
         . " times.");
}
[root@niobe-02 stap]# stap -v ext3.stp
Created temporary directory "/tmp/stapmLOGDr"
Searched '/usr/share/systemtap/tapset/2.6.9-22.EL/*.stp', match count 0
Searched '/usr/share/systemtap/tapset/2.6.9/*.stp', match count 0
Searched '/usr/share/systemtap/tapset/2.6/*.stp', match count 0
Searched '/usr/share/systemtap/tapset/*.stp', match count 4
Pass 1: parsed user script and 4 library script(s).
parsed '*' -> func '*'
pattern 'ext3*' matches module 'ext3'
focused on module 'ext3' = [e0986000-e09a2849, bias 0]
WARNING: dwfl_module_getdwarf() : Unsupported relocation type
WARNING: no dwarf info found for module ext3
semantic error: no match for probe point
         while: resolving probe point module("ext3*").function("*")
Pass 2: analyzed user script.  2 probe(s), 10 function(s), 1 global(s).
Pass 2: analysis failed.  Try again with '-v' (verbose) option.
Running /bin/rm -rf /tmp/stapmLOGDr

Version-Release number of selected component (if applicable):
systemtap-0.4-0-EL4.i386.rpm

How reproducible:
Always

Steps to Reproduce:
1.see above
2.
3.
  

Additional info:
Comment 1 Frank Ch. Eigler 2005-10-10 17:35:48 EDT
Roland, could you assess whether this is a regression in kernel build, or
something fixed in an elfutils refresh used in current systemtap builds?
Comment 2 Roland McGrath 2005-10-10 17:49:59 EDT
This is a build issue already fixed in the 0.4.1 build.
I asked Kevin to file this bug so that we make sure the U3 build gets
regression-tested in the errata QA process.
Comment 5 Frank Ch. Eigler 2005-10-20 12:39:40 EDT
This issue appears to be still there in the .22EL x86-64 build, with CVS
systemtap and elfutils-0.115.
Comment 6 Frank Ch. Eigler 2005-10-20 15:17:40 EDT
Specifically, the problem is that elfutils uses a bunch of dlopen'd shared
libraries.  If these libraries cannot be loaded at run time, strange errors such
as these occur.
Comment 7 Elena Zannoni 2005-10-21 16:19:14 EDT
Dev ack for rhel4 u3
Comment 8 Roland McGrath 2005-11-14 22:17:13 EST
This is already fixed in current builds.  It just needs final testing when there
is an erratum candidate build ready for the next round.
Comment 11 Red Hat Bugzilla 2006-03-07 13:43:48 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2006-0088.html

Note You need to log in before you can comment on or make changes to this bug.