Bug 170352 - Please do not backport LSB support in nscd to FC3/FC4/RHEL3/RHEL4
Summary: Please do not backport LSB support in nscd to FC3/FC4/RHEL3/RHEL4
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-10-10 21:40 UTC by Bill Nottingham
Modified: 2016-11-24 12:44 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-11 07:30:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bill Nottingham 2005-10-10 21:40:01 UTC
... because it will break chkconfig.

[root@apone ~]# rpm -q chkconfig
chkconfig-1.3.20-2
[root@apone ~]# chkconfig  --add nscd
[root@apone ~]# ls /etc/rc*.d/*nscd
/etc/rc0.d/K74nscd  /etc/rc2.d/K74nscd  /etc/rc4.d/K74nscd  /etc/rc6.d/K74nscd
/etc/rc1.d/K74nscd  /etc/rc3.d/K74nscd  /etc/rc5.d/K74nscd
[root@apone ~]# chkconfig --level 345 nscd on
[root@apone ~]# ls /etc/rc*.d/*nscd
/etc/rc0.d/K74nscd  /etc/rc2.d/K74nscd  /etc/rc4.d/S-1nscd  /etc/rc6.d/K74nscd
/etc/rc1.d/K74nscd  /etc/rc3.d/S-1nscd  /etc/rc5.d/S-1nscd

If you add a:

# Required-Stop:

line with no deps, chkconfig will not make the (invalid) S-1 links, but will set
both the stop and start priority to 50 (as it's using the LSB code.)

I'll fix the devel chkconfig to use the chkconfig: priorities as a starting base
instead of 50/50, but that fix almost certainly won't be backported to
RHEL3/RHEL4, and probably not to FC3/FC4.

The fix for where it creates the S-1 links should be backported to RHEL3/RHEL4,
but not until U3/U7.

Comment 1 Jakub Jelinek 2005-10-11 07:30:15 UTC
Ok, ok.  I'll remember that.

Comment 2 Bill Nottingham 2005-11-11 20:21:03 UTC
Oops. It's already in FC-4. Time to go push an update. :)


Note You need to log in before you can comment on or make changes to this bug.