Bug 1703883 - [ci] must-gather pod test causes test case failures
Summary: [ci] must-gather pod test causes test case failures
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Master
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 4.1.0
Assignee: Luis Sanchez
QA Contact: zhou ying
URL:
Whiteboard:
: 1704470 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-29 02:01 UTC by Clayton Coleman
Modified: 2019-06-04 10:48 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:48:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:48:17 UTC

Description Clayton Coleman 2019-04-29 02:01:46 UTC
The must gather pod launched by the CI is causing the crashlooping pods test to fail. It may be that the test should ignore pods that are run once and have no failing containers, but should be investigated.

https://openshift-gce-devel.appspot.com/build/origin-ci-test/logs/release-openshift-origin-installer-e2e-aws-4.1/340

[Feature:Platform] Managed cluster should have no crashlooping pods in core namespaces over two minutes [Suite:openshift/conformance/parallel] 2m2s

fail [github.com/openshift/origin/test/extended/operators/cluster.go:109]: Expected
    <[]string | len:1, cap:1>: [
        "Pod openshift-must-gather-hzg6c/must-gather-tnvmr was pending entire time: unknown error",
    ]
to be empty

Comment 2 Luis Sanchez 2019-05-01 16:26:18 UTC
Occurs when crashlooping pods test and must-gather test run concurrently.

Fixed by: https://github.com/openshift/origin/pull/22712

Comment 3 Luis Sanchez 2019-05-01 16:26:51 UTC
*** Bug 1704470 has been marked as a duplicate of this bug. ***

Comment 4 Luis Sanchez 2019-05-13 15:07:42 UTC
Fixed in 4.1.0

Comment 5 zhou ying 2019-05-15 03:37:23 UTC
Confirmed with latest payload, the issue has fixed:
Payload: 4.1.0-0.nightly-2019-05-14-202907

Open 2 terminals, at the same time, one run `oc adm must-gather` , other one run `openshift-tests run-test "[Feature:Platform] Managed cluster should have no crashlooping pods in core namespaces over two minutes [Suite:openshift/conformance/parallel]" ` . no error found.

Comment 7 errata-xmlrpc 2019-06-04 10:48:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.