Bug 170390 - Squid is too old in RHEL3
Squid is too old in RHEL3
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: squid (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks: 170445
  Show dependency treegraph
 
Reported: 2005-10-11 06:08 EDT by Martin Stransky
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-28 06:08:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cache.log for 2.5S11-1 (5.51 KB, application/octet-stream)
2005-10-24 12:13 EDT, Bob Gorman
no flags Details

  None (edit)
Description Martin Stransky 2005-10-11 06:08:34 EDT
Description of problem:

Squid in current RHEL3 doesn't work properly. There were discovered many issues
 between version used in RHEL3 and current stable and there are many backported
patches. We need to start with new clear package with all fixes.

The current upstream stable version may work properly (Bug 160704 Comment #34)


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bob Gorman 2005-10-13 11:45:54 EDT
Thank you for this, Martin.  I look forward to your release of a compiled 
version for testing under RHEL3 for i386. In specific: squid-2.5.STABLE11.
Comment 2 Bob Gorman 2005-10-13 13:25:12 EDT
There is a related bug here:

    https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=170392
Comment 3 Martin Stransky 2005-10-18 09:48:19 EDT
Page with packages from upstream and hopefully fixed packages for RHEL3/4 is here:

http://people.redhat.com/stransky/squid/
Comment 4 Bob Gorman 2005-10-18 10:14:22 EDT
Can you compile them, please?
Comment 5 Martin Stransky 2005-10-19 09:58:51 EDT
okay, they are there too.
Comment 6 Bob Gorman 2005-10-21 15:32:35 EDT
I put squid-2.5.STABLE11-1.RHEL3.i386.rpm into production today.

It did not die after 10 minutes as the squid-2.5.STABLE3-6.3E.X branch did.

This has been in production for four hours, and no crashes.  I'll keep it in 
production and see how it goes.

While no crashes, the cache.log continues to have these messages:

2005/10/21 13:39:41| ctx: enter level  0: 'http://megacharts.finance.lycos.com/
Megacharts/MChartISAPI.dll?...'
2005/10/21 13:39:41| WARNING: unparseable HTTP header field {HTTP/1.1 200 OK}

2005/10/21 13:55:45| httpReadReply: Excess data from "GET http://servedby.
advertising.com/site=695501/mnum=262775/bins=1/rich=0"


Comment 8 Martin Stransky 2005-10-24 10:50:43 EDT
(In reply to comment #6)
> While no crashes, the cache.log continues to have these messages:

It looks like your users visit some broken sites. Could you attach more lines
from your cache.log?
Comment 9 Bob Gorman 2005-10-24 12:13:07 EDT
Created attachment 120308 [details]
cache.log for 2.5S11-1

Here is the cache.log file so far.  This from squid-2.5.STABLE11-1.RHEL3.
Comment 10 Martin Stransky 2005-10-26 04:19:46 EDT
(In reply to comment #9)
> Here is the cache.log file so far.  This from squid-2.5.STABLE11-1.RHEL3.

It's not a bug. It's a feature. Squid checks response from servers and refuses
pages if they aren't correct. You don't have to care about it if your users
don't complain.
Comment 11 Bob Gorman 2005-10-28 12:52:25 EDT
Do you think you will move squid-2.5.STABLE11 into an official RHEL3/4 update 
release?
Comment 12 Bob Gorman 2005-12-28 13:04:14 EST
I see that the Status has been changed to Closed with a Resolution of 
NextRelease.  What will be the end-result of this?  Does it mean that squid-2.5.
STABLE11 will be used in the next official Update release of RHEL3/4?
Comment 13 Martin Stransky 2006-01-03 08:17:39 EST
It means that the latest stable release will be used in RHEL5 unless RH managers
decide otherwise. 
Comment 14 Bob Gorman 2006-01-03 11:11:17 EST
This bug report and the bug reports it supersedes are about problems with squid 
under RHEL3.  How is preematively fixing the problems in RHEL5 going to solve 
the problems with RHEL3?  When will the problem bugs be addressed in RHEL3?  As 
far as I can tell they have not been addressed, yet you have closed them all in 
bugzilla, with the final resolution that the "latest stable release will be used 
in RHEL5".  That does not address RHEL3 - does it?  Please explain.
Comment 15 Martin Stransky 2006-01-06 08:33:35 EST
Fixed packages are available on my testing page. New stable packages will not be
released for RHEL3/4. It's the fact and you and I can't do anything with it.
This bug can be closed as WONTFIX as NEXTRELEASE, there isn't any difference.
And, please, bugzilla is only a bug-tracking system, if you want to complain you
have to use another way (Issue-tracker).

Note You need to log in before you can comment on or make changes to this bug.