Bug 170392 - Squid is too old in RHEL4
Squid is too old in RHEL4
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: squid (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Bacovsky
RHEL4U3NAK
:
Depends On:
Blocks: 176344
  Show dependency treegraph
 
Reported: 2005-10-11 06:13 EDT by Martin Stransky
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2007-0251
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 19:27:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Stransky 2005-10-11 06:13:11 EDT
Description of problem:

Squid in current RHEL4 doesn't work properly. There were discovered many issues
between version used in RHEL4 and current stable and there are many backported
patches. We need to start with new clear package with all fixes.

The current upstream stable version may work properly (Bug 160704 Comment #34)

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 rambler8 2005-10-13 09:08:06 EDT
Redhat needs to promptly release an update to completely resolve all issues 
that have been resolved in squid-2.5.STABLE-11 plus the delay pool problem 
solved prior to STABLE-12 or I will be recommending that we not renew our 3 
RHEL ES subscriptions. 

The reasons I recommended RHEL in the first place was 1)quality controll and 2)
RHN provided time and cost savings value when looking for and installing 
updates. Unfortunately neither benefit is being realized.

The current squid packages are critically broken and have been for 3+ months. 
Our squid servers were crashing once or twice per day with the current RHEL 
released squid package. Redhat has tried unsucessfully for 3+ months to back 
port patches to resolve the issues. I have built, installed and used an RPM 
from the squid-2.5.STABLE-11 source which resolved all problems encountered 
with the RHEL squid packages. I installed these RPMs two weeks ago and squid 
has not crashed since. Redhat has built and distributed a squid RPM package for 
Fedora 4 that is also built from squid-2.5.STABLE-11 and includes the delay 
pool patch.

If an update will not be released within the next week, I an invite the RHEL 
managers to explain, in this forum, why they will not allow a new package to be 
released that fixes these critical service interrupting bugs and why, in that 
case, we should renew our RHN subscriptions if we are not receiving the updates 
that we paid for.
Comment 2 Martin Stransky 2005-10-18 09:48:14 EDT
Page with packages from upstream and hopefully fixed packages for RHEL3/4 is here:

http://people.redhat.com/stransky/squid/
Comment 6 Bojan Smojver 2006-06-01 21:10:32 EDT
Yes, please. Current version of Squid in RHEL4 has problems with Java/NTLM,
which makes it really annoying in most corporate environments.
Comment 7 Bojan Smojver 2006-06-02 05:33:12 EDT
Current stable version, as of 30 May 2006, is squid-2.5.STABLE14:

http://www.squid-cache.org/Versions/v2/2.5/
Comment 8 Martin Stransky 2006-08-03 06:19:12 EDT
The latest 2.5 and 2.6 packages for RHEL4 are available on my squid page...
Comment 9 RHEL Product and Program Management 2006-08-18 13:16:26 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 11 Martin Stransky 2006-09-04 04:17:55 EDT
Testing packages are here:

http://people.redhat.com/stransky/squid/

so anybody can check them.
Comment 12 Bojan Smojver 2006-12-17 17:38:34 EST
Could you build 2.6.STABLE6 for RHEL4 and upload to the above page? TIA!
Comment 13 Martin Stransky 2007-01-10 04:39:24 EST
(In reply to comment #12)
> Could you build 2.6.STABLE6 for RHEL4 and upload to the above page? TIA!

I'm going to update directly to STABLE7 there, it should be here in a week.
Comment 14 Bojan Smojver 2007-01-10 15:52:33 EST
Thanks. Much appreciated.
Comment 15 Martin Stransky 2007-01-15 10:42:34 EST
The page was updated.
Comment 16 Bojan Smojver 2007-01-15 16:50:59 EST
Excellent! Thanks.
Comment 17 rambler8 2007-01-15 20:08:44 EST
Are the "Differences between current RHEL4 package and the latest upstream 
package" up-to-date for the squid-2.6.STABLE7-1.RHEL4 package?
Comment 18 Martin Stransky 2007-01-16 05:23:18 EST
(In reply to comment #17)
> Are the "Differences between current RHEL4 package and the latest upstream 
> package" up-to-date for the squid-2.6.STABLE7-1.RHEL4 package?

No, it's for the latest 2.5 line (i.e. for STABLE14).
Comment 22 Red Hat Bugzilla 2007-05-01 19:27:16 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0251.html

Note You need to log in before you can comment on or make changes to this bug.