Bug 1703935 - assertion failure since 1.27.0
Summary: assertion failure since 1.27.0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libuv
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Stephen Gallagher
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-29 07:28 UTC by Remi Collet
Modified: 2019-06-06 01:29 UTC (History)
7 users (show)

Fixed In Version: libuv-1.28.0-2.fc29 libuv-1.28.0-2.fc30 libuv-1.28.0-2.fc28 libuv-1.29.1-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-05 02:43:35 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github bwoebi php-uv issues 66 None None None 2019-04-29 07:37:29 UTC
Github libuv libuv issues 2287 None None None 2019-05-02 12:13:52 UTC

Description Remi Collet 2019-04-29 07:28:34 UTC
Working on uv extension for PHP.
https://github.com/bwoebi/php-uv


With 1.26.0 build + test suite passes

With 1.27.0 (or 1.28.0) we encounter a segfault

#0  0x00007ffff72d557f in raise () from /lib64/libc.so.6
#1  0x00007ffff72bf895 in abort () from /lib64/libc.so.6
#2  0x00007ffff72bf769 in __assert_fail_base.cold.0 () from /lib64/libc.so.6
#3  0x00007ffff72cda26 in __assert_fail () from /lib64/libc.so.6
#4  0x00007ffff70d374d in uv.make_close_pending () from /lib64/libuv.so.1
#5  0x00007ffff70cd430 in ?? () from /lib64/libuv.so.1
#6  0x00007ffff70d3b65 in uv_run () from /lib64/libuv.so.1
#7  0x00007ffff7fb1917 in zif_uv_run (execute_data=<optimized out>, return_value=<optimized out>) at /work/GIT/pecl-and-ext/uv/php_uv.c:3494
#8  0x00005555558a9e3d in ZEND_DO_ICALL_SPEC_RETVAL_UNUSED_HANDLER () at /usr/src/debug/php-7.2.17-1.fc29.remi.x86_64/Zend/zend_vm_execute.h:573
#9  execute_ex (ex=0x2) at /usr/src/debug/php-7.2.17-1.fc29.remi.x86_64/Zend/zend_vm_execute.h:59747
#10 0x00005555558b2a06 in zend_execute (op_array=0x7ffff6e75460, op_array@entry=0x7ffff6e92580, return_value=return_value@entry=0x7ffff6e1d030)
    at /usr/src/debug/php-7.2.17-1.fc29.remi.x86_64/Zend/zend_vm_execute.h:63776
#11 0x000055555580ca5b in zend_execute_scripts (type=type@entry=8, retval=0x7ffff6e1d030, retval@entry=0x0, file_count=file_count@entry=3)
    at /usr/src/debug/php-7.2.17-1.fc29.remi.x86_64/Zend/zend.c:1498
#12 0x00005555557a8190 in php_execute_script (primary_file=<optimized out>) at /usr/src/debug/php-7.2.17-1.fc29.remi.x86_64/main/main.c:2594
#13 0x00005555558b4fe0 in do_cli (argc=64, argv=0x555555a4c0f0) at /usr/src/debug/php-7.2.17-1.fc29.remi.x86_64/sapi/cli/php_cli.c:1011
#14 0x0000555555661c12 in main (argc=64, argv=0x555555a4c0f0) at /usr/src/debug/php-7.2.17-1.fc29.remi.x86_64/sapi/cli/php_cli.c:1403


Reported in upstream as https://github.com/bwoebi/php-uv/issues/66

But looks like a lilbuv issue (regression)

Comment 1 Tom Hughes 2019-04-29 07:36:20 UTC
That's not a segmentation fault, it's an assertion failure.

Comment 2 Stephen Gallagher 2019-05-02 12:14:42 UTC
I've reported this upstream to libuv and CCed Remi on it in case they need more information.

Comment 3 Fedora Update System 2019-05-03 16:55:00 UTC
libuv-1.28.0-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-e080b52140

Comment 4 Fedora Update System 2019-05-03 16:55:04 UTC
libuv-1.28.0-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-91e121bae6

Comment 5 Fedora Update System 2019-05-03 16:55:08 UTC
libuv-1.28.0-2.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-9d84fa1a18

Comment 6 Fedora Update System 2019-05-03 16:55:12 UTC
libuv-1.28.0-2.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-ee2275814f

Comment 7 Fedora Update System 2019-05-04 01:12:13 UTC
libuv-1.28.0-2.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-ee2275814f

Comment 8 Fedora Update System 2019-05-04 01:57:54 UTC
libuv-1.28.0-2.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-9d84fa1a18

Comment 9 Fedora Update System 2019-05-04 02:58:30 UTC
libuv-1.28.0-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-e080b52140

Comment 10 Fedora Update System 2019-05-04 03:13:06 UTC
libuv-1.28.0-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-91e121bae6

Comment 11 Fedora Update System 2019-05-05 02:43:35 UTC
libuv-1.28.0-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2019-05-06 00:45:47 UTC
libuv-1.28.0-2.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2019-05-14 01:06:05 UTC
libuv-1.28.0-2.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2019-05-16 00:12:56 UTC
libuv-1.29.0-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-69f42e0b0d

Comment 15 Fedora Update System 2019-05-17 02:38:12 UTC
libuv-1.29.0-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-69f42e0b0d

Comment 16 Fedora Update System 2019-05-21 20:32:08 UTC
libuv-1.29.1-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-65a15fb0a9

Comment 17 Fedora Update System 2019-05-22 10:51:09 UTC
libuv-1.29.1-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-65a15fb0a9

Comment 18 Fedora Update System 2019-06-06 01:29:13 UTC
libuv-1.29.1-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.