Bug 17043 - Kernel will not compile.
Summary: Kernel will not compile.
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-28 16:23 UTC by Jeremy Pitman
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-28 22:01:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of rpm -Va (98.97 KB, text/plain)
2000-08-30 17:54 UTC, Jeremy Pitman
no flags Details
Output of rpm -Va with just the missing files. (43.20 KB, text/plain)
2000-08-30 17:54 UTC, Jeremy Pitman
no flags Details

Description Jeremy Pitman 2000-08-28 16:23:33 UTC
Currently running kernel 2.2.16-3.  When I tried to compile (make bzImage)
the kernel after running make dep, I get this error:

scripts/split-include.c:26: errno.h: No such file or directory
make: *** [script/spilt-include] error 1

I have a single processor [PPRO 200] with 64 megs of memory.  All drives 
are ide, no scsi.

Comment 1 Michael K. Johnson 2000-08-28 18:47:44 UTC
Tried "make mrproper" first, before "make dep"?

Comment 2 Jeremy Pitman 2000-08-28 19:18:31 UTC
Yes I have.  Same error.  Anything else?

Comment 3 Michael K. Johnson 2000-08-28 20:39:00 UTC
Oops, sorry I read that too quick.  Check to make sure that
the /usr/include/asm and /usr/include/linux symlinks are in
place.

Comment 4 Jeremy Pitman 2000-08-28 21:30:25 UTC
Ok.  I have a asm link in /linux/include.  The asm link is to asm-i386.  I have 
a /linux/include/linux which is not a link.  I have a linux link in /usr/src, 
which is a link to /usr/src/Linux-2.2.16-3.  If I had a link issue would it 
still "make mrproper" or "make dep"?  Is there anything else that could cause 
it besides a bad link?  I was thinking a environment path problem?

Comment 5 Michael K. Johnson 2000-08-28 21:37:49 UTC
No, no, not /linux/include or even /usr/src/linux/include.  I'm
talking about /usr/include/asm and /usr/include/linux.

Comment 6 Jeremy Pitman 2000-08-28 22:01:08 UTC
Nope I have no links asm or linux in /usr/include.  What should these links 
link to?

Comment 7 Bill Nottingham 2000-08-29 15:06:54 UTC
In 6.2, /usr/include/asm -> /usr/src/linux/include/asm
 /usr/include/linux -> /usr/src/linux/include/linux.

Comment 8 Jeremy Pitman 2000-08-29 15:10:10 UTC
Ok, I've added the symbolic links in the /usr/include.  I have another RedHat 
box so I looked there to figure where the links should point.  I ran "make 
mrproper", "make menuconfig", "make dep", then "make bzImage".  I still have 
the same error.  Are there any other links that I may not have setup?

Comment 9 Michael K. Johnson 2000-08-29 21:22:21 UTC
/usr/src/linux -> /usr/src/linux-2.2.16

Comment 10 Jeremy Pitman 2000-08-30 12:13:59 UTC
Yep, that has been correct.  The only links so far that were not correct were 
the links in /usr/include.  Now those links are fixed and still it will not 
compile.  Anything else I could try?  I do need to get it running fairly soon 
as I'm not currently making back-ups due to the fact it will not compile.

Comment 11 Michael K. Johnson 2000-08-30 13:13:09 UTC
Please run these commands:
rpm -q glibc-devel
rpm -V glibc-devel
find /usr/include -type f -name errno.h

Comment 12 Jeremy Pitman 2000-08-30 13:52:48 UTC
Cool now it seems like we're getting somewhere.  Here are the results:

rpm -q glibc-devel
glibc-devel-2.1.3-15

rpm -V glibc-devel
missing /usr/include/errno.h

find . -type f -name errno.h
./bits/errno.h
./sys/errno.h

Ok, if it is missing errno.h in /usr/include where can I get a replacement, and 
is glibc-devel-2.1.3-15 the correct version?


Comment 13 Michael K. Johnson 2000-08-30 14:45:21 UTC
Yeah, I think that's the right version, but the version shouldn't
matter.  Just re-install the glibc-devel package with
rpm -Uvh --force /path/to/glibc-devel-2.1.3-15.i386.rpm

Comment 14 Jeremy Pitman 2000-08-30 15:03:11 UTC
Ok, that error is now gone but now I get this:

make: egsc: Command not found
make: *** [init/main.o] Error 127

What does that mean?

Comment 15 Michael K. Johnson 2000-08-30 16:11:56 UTC
Look at the output of
rpm -Va
and see what files are missing/damaged.

Comment 16 Jeremy Pitman 2000-08-30 17:54:29 UTC
Created attachment 3100 [details]
Output of rpm -Va

Comment 17 Jeremy Pitman 2000-08-30 17:54:58 UTC
Created attachment 3101 [details]
Output of rpm -Va with just the missing files.

Comment 18 Michael K. Johnson 2000-08-30 18:37:14 UTC
Those missing files shouldn't be a problem.

If that really says "egsc" instead of "egcs" you have a data
corruption problem for use.

Comment 19 Jeremy Pitman 2000-08-30 18:41:46 UTC
Ok so if it is data corruption because it does say "make: egsc: Command not 
found", what do I do to fix it?

Comment 20 Michael K. Johnson 2000-08-30 18:45:00 UTC
That would generally be a hardware problem.  You could try re-installing
the kernel source (rpm -Uvh --force kernel-source*rpm) and see if that
helps.


Note You need to log in before you can comment on or make changes to this bug.