Bug 1704315 - root FTBFS:
Summary: root FTBFS:
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: root
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mattias Ellert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1675096
Blocks: F31FTBFS PYTHON38 1732841
TreeView+ depends on / blocked
 
Reported: 2019-04-29 14:15 UTC by Miro Hrončok
Modified: 2019-07-31 22:40 UTC (History)
1 user (show)

Fixed In Version: root-6.16.00-5.fc31 root-6.16.00-5.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-27 01:02:19 UTC
Type: Bug


Attachments (Terms of Use)
root.log from Koji (59.92 KB, text/plain)
2019-04-29 14:15 UTC, Miro Hrončok
no flags Details

Description Miro Hrončok 2019-04-29 14:15:54 UTC
Created attachment 1559941 [details]
root.log from Koji

Package root FTBFS due to a missing Python 2 dependency.
This will block it's rebuilt for Python 3.8.

ERROR: Command failed: 
 # /usr/bin/dnf builddep --installroot /var/lib/mock/f31-build-16086120-1152414/root/ --setopt=install_weak_deps=0 /var/lib/mock/f31-build-16086120-1152414/root//builddir/build/SRPMS/root-6.16.00-4.fc31.src.rpm --setopt=tsflags=nocontexts
Error: 
 Problem: package libhdfs-2.7.6-5.fc29.x86_64 requires hadoop-hdfs = 2.7.6-5.fc29, but none of the providers can be installed
  - package hadoop-devel-2.7.6-5.fc29.x86_64 requires libhdfs.so.0.0.0()(64bit), but none of the providers can be installed
  - package hadoop-devel-2.7.6-5.fc29.x86_64 requires libhdfs(x86-64) = 2.7.6-5.fc29, but none of the providers can be installed
  - package hadoop-hdfs-2.7.6-5.fc29.noarch requires hadoop-common = 2.7.6-5.fc29, but none of the providers can be installed
  - conflicting requests
  - nothing provides txw2 needed by hadoop-common-2.7.6-5.fc29.noarch
(try to add '--skip-broken' to skip uninstallable packages)


Full root.log attached.

Comment 1 Miro Hrončok 2019-04-29 14:17:25 UTC
Correction, txw2 is not a Python 2 dependency.

Comment 2 Mattias Ellert 2019-04-29 15:37:19 UTC
This is a due to bug #1675096 (hadoop-devel not installable).

If that is fixed, no change is needed for the root package.

If it won't be fixed, the Fedora 31 build should be changed to build without hadoop support (like the EPEL 7 build).

I have been waiting for some action from the hadoop maintainers to decide what path to take, but they have neither fixed their package nor orphaned it, so it is not clear what choice is the right one.

Comment 3 Fedora Update System 2019-05-18 18:20:26 UTC
root-6.16.00-5.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-cf4dcd815a

Comment 4 Fedora Update System 2019-05-19 00:51:38 UTC
root-6.16.00-5.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-cf4dcd815a

Comment 5 Fedora Update System 2019-05-27 01:02:19 UTC
root-6.16.00-5.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.