Bug 1704389 - Drop unused machine fields
Summary: Drop unused machine fields
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.1.0
Assignee: Alberto
QA Contact: Jianwei Hou
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-29 16:05 UTC by Alberto
Modified: 2019-06-04 10:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:48:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:48:17 UTC

Description Alberto 2019-04-29 16:05:54 UTC
Description of problem:

drop unused machine fields:

Some fields are not used by our controllers and we were keeping them for avoiding drift from upstream. However given current upstream flux we'd like to reduce the scope of the machine API as much as possible to what's actually used today.

machine.spec.versions -- we don't use it today
machine.spec.configsource -- we don't use dynamic kubelet config
machine.spec.providerSpec.machineClass -- we are not shipping the machine class resource at this time
machine.status.versions -- we are not setting this yet
machine.status.conditions -- we are not setting these node conditions up to machine objects yet

Version-Release number of selected component (if applicable):
4.1

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Jianwei Hou 2019-05-05 05:20:27 UTC
Verified in 4.1.0-0.nightly-2019-05-04-054221

The fields in the description have been dropped.

Comment 5 errata-xmlrpc 2019-06-04 10:48:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.