Bug 1704412 - cinder-backup service not configured per THT parameter values
Summary: cinder-backup service not configured per THT parameter values
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 15.0 (Stein)
Assignee: Alan Bishop
QA Contact: Tzach Shefi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-29 16:40 UTC by Alan Bishop
Modified: 2019-09-26 10:49 UTC (History)
1 user (show)

Fixed In Version: openstack-tripleo-heat-templates-10.5.1-0.20190509160423.4dac4dc.el8ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:21:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1826897 0 None None None 2019-04-29 16:40:07 UTC
OpenStack gerrit 656364 0 None None None 2019-04-29 16:44:14 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:21:53 UTC

Description Alan Bishop 2019-04-29 16:40:07 UTC
When the cinder-backup service is deployed, the service is not being configured with any of the THT parameters. Instead, it ends up running with an entirely default configuration (which happens to use the swift backend driver).

The problem can be observed by deploying cinder-backup, and checking the backup_driver setting in the DEFAULT section of cinder.conf. TripleO should always configure the backup_driver, even when using swift (the default swift). In other words, when the backup service is deployed, the backup_driver should never be left commented out.

Comment 1 Alan Bishop 2019-05-14 19:55:22 UTC
No doc text required. This was a regression introduced and fixed in stein prior to the release of OSP-15.

Comment 5 Tzach Shefi 2019-05-22 09:26:00 UTC
Verified on:
openstack-tripleo-heat-templates-10.5.1-0.20190509160423.4dac4dc.el8ost.noarch


Deployed Cinder backup service via adding on overcloud_deploy.sh -> 
--environment-file /usr/share/openstack-tripleo-heat-templates/environments/cinder-backup.yaml \


Review cinder.conf

    255 # Driver to use for backups. (string value)
    256 #backup_driver = cinder.backup.drivers.swift.SwiftBackupDriver
    257 backup_driver=cinder.backup.drivers.swift.SwiftBackupDriver

As seen above this happens to be an LVM deployment defaults to swift as Cinder backup any way. 
But line 257 the backup_driver is present not commented out. 


On another deployment this time with a later THT, deployed with ceph
openstack-tripleo-heat-templates-10.5.1-0.20190520170359.0c31f04.el8ost.noarch
    260 # Driver to use for backups. (string value)
    261 #backup_driver = cinder.backup.drivers.swift.SwiftBackupDriver
    262 backup_driver=cinder.backup.drivers.ceph.CephBackupDriver

backup_driver was never commented out, looks OK to verify.

Comment 7 errata-xmlrpc 2019-09-21 11:21:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.