Bug 17045 - X starts, but has no fonts
X starts, but has no fonts
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
alpha Linux
high Severity high
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On: 17163
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-28 12:54 EDT by Simon Hill
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-20 13:27:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Hill 2000-08-28 12:54:18 EDT
After a clean install of RH6.2 on an alpha, there is a X problem of some
sort. When running Xconfigurator at the point where it tests the
configuration, X comes up, and the dialog box which normally ask if the
display is satisfactory comes up, but it is completely blank! There are no
buttons and no text. It does produce an XF86Config file, but starting X has
the same problem - Gnome comes up, but there is no text, all the windows
are blank. I am not sure whether the problem is with the generated
XF86Config, or with xfs. However, if I transfer a working XF86Config file
from an identical machine running 6.1, the same problem occurs.
Comment 1 Simon Hill 2000-08-29 00:47:04 EDT
This is a seriously weird bug. Since I have a working 6.1 system with same mobo
and video (UDB/TGA), I downgraded all the XFree86 rpms to the versions on the
6.1 CD. Found and fixed all the .rpmnew files, and restarted xfs. Tryed
Xconfigurator, but it wouldn't produce a valid configuration (this happened also
on 6.1 IIRC). Grabbed XF86Config off the working 6.1 system. This works, but
once again X/Gnome comes up with blank dialog boxes and file manager windows.

I think the problem must be in whatever widget library Gnome and XTest use, or
in a font (I have them all installed, but didn't back them off to the 6.1
versions). Interestingly enough, the little enlightenment popup help boxes DO
come up and DO have text in them.

I will keep this bug updated as I discover more.

Comment 2 Simon Hill 2000-08-29 09:31:25 EDT
This appears to be a Gnome bug, not an X bug. I tried running Gnome apps on the
working 6.1 systems display. Gnorpm did not come up at all. Gcalc came up, but
was blank. I tried KDE apps, and they worked just fine. So I went back to the
original system and set /etc/sysconfig/desktop to KDE and did a telinit 5. KDM
came up just fine. I had tried this previously with GDM, but had the blank panel
problem.

Reassigning to gnome-core.
Comment 3 Simon Hill 2000-09-01 00:10:50 EDT
This appears to be due to a bug in the kernel FP exception code for EV4
architecture.
Comment 4 Need Real Name 2001-02-20 12:38:54 EST
I have also discovered this bug, and have tracked it to something even wierder.

If you boot from the SRM, the problem shows itself.  However, if you boot from 
MILO, the problem goes away.

I am currently compiling the FP kernel exception patch to see if that helps.  
But in the mean time, it is an interesting note to find that booting from MILO 
will cause this problem to go away.

Comment 5 Phil Copeland 2001-06-04 12:47:19 EDT
I don't have access to an ev4 box, can't help on this.


Note You need to log in before you can comment on or make changes to this bug.