Bug 17045 - X starts, but has no fonts
Summary: X starts, but has no fonts
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 6.2
Hardware: alpha
OS: Linux
high
high
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On: 17163
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-28 16:54 UTC by Simon Hill
Modified: 2008-05-01 15:37 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2001-02-20 18:27:28 UTC


Attachments (Terms of Use)

Description Simon Hill 2000-08-28 16:54:18 UTC
After a clean install of RH6.2 on an alpha, there is a X problem of some
sort. When running Xconfigurator at the point where it tests the
configuration, X comes up, and the dialog box which normally ask if the
display is satisfactory comes up, but it is completely blank! There are no
buttons and no text. It does produce an XF86Config file, but starting X has
the same problem - Gnome comes up, but there is no text, all the windows
are blank. I am not sure whether the problem is with the generated
XF86Config, or with xfs. However, if I transfer a working XF86Config file
from an identical machine running 6.1, the same problem occurs.

Comment 1 Simon Hill 2000-08-29 04:47:04 UTC
This is a seriously weird bug. Since I have a working 6.1 system with same mobo
and video (UDB/TGA), I downgraded all the XFree86 rpms to the versions on the
6.1 CD. Found and fixed all the .rpmnew files, and restarted xfs. Tryed
Xconfigurator, but it wouldn't produce a valid configuration (this happened also
on 6.1 IIRC). Grabbed XF86Config off the working 6.1 system. This works, but
once again X/Gnome comes up with blank dialog boxes and file manager windows.

I think the problem must be in whatever widget library Gnome and XTest use, or
in a font (I have them all installed, but didn't back them off to the 6.1
versions). Interestingly enough, the little enlightenment popup help boxes DO
come up and DO have text in them.

I will keep this bug updated as I discover more.



Comment 2 Simon Hill 2000-08-29 13:31:25 UTC
This appears to be a Gnome bug, not an X bug. I tried running Gnome apps on the
working 6.1 systems display. Gnorpm did not come up at all. Gcalc came up, but
was blank. I tried KDE apps, and they worked just fine. So I went back to the
original system and set /etc/sysconfig/desktop to KDE and did a telinit 5. KDM
came up just fine. I had tried this previously with GDM, but had the blank panel
problem.

Reassigning to gnome-core.


Comment 3 Simon Hill 2000-09-01 04:10:50 UTC
This appears to be due to a bug in the kernel FP exception code for EV4
architecture.


Comment 4 Need Real Name 2001-02-20 17:38:54 UTC
I have also discovered this bug, and have tracked it to something even wierder.

If you boot from the SRM, the problem shows itself.  However, if you boot from 
MILO, the problem goes away.

I am currently compiling the FP kernel exception patch to see if that helps.  
But in the mean time, it is an interesting note to find that booting from MILO 
will cause this problem to go away.



Comment 5 Phil Copeland 2001-06-04 16:47:19 UTC
I don't have access to an ev4 box, can't help on this.




Note You need to log in before you can comment on or make changes to this bug.