Bug 170456 - [RHEL 4] savecore should allow gzip on-the-fly
Summary: [RHEL 4] savecore should allow gzip on-the-fly
Status: CLOSED DUPLICATE of bug 168641
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: diskdumputils (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Akira Imamura
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On: 168641
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-10-11 21:46 UTC by Brian Long
Modified: 2007-11-30 22:07 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-23 00:02:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brian Long 2005-10-11 21:46:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050921 Red Hat/1.0.7-1.4.1 Firefox/1.0.7

Description of problem:
savecore needs to support a new CLI flag that integrates gzip compression on-the-fly so vmcore does not take so much space in /var/crash.  I had a 64GB host netdump the other day and it took 18 hours over an OC-12 WAN to dump.  When I gzip'd the core, it was ~9GB.  Solaris compresses their vmcore files by default.  I would like to see an option added to /etc/sysconfig/diskdump that /etc/init.d/diskdump would read and pass to $SAVECORE.  This option would enable gzip on-the-fly.  It might increase the time savecore takes to run, but it would mean I wouldn't need to have a 64GB /var/crash and a 64GB dump partition (both a waste) if I want to transition from netdump to diskdump.

Version-Release number of selected component (if applicable):
diskdumputils-1.1.8-1

How reproducible:
Always

Steps to Reproduce:
1. Initiate kernel dump with diskdump enabled
2. /var/crash/vmcore is uncompressed

  

Actual Results:  /var/crash/vmcore is the size of RAM

Expected Results:  /var/crash/vmcore.gz would be a fraction of the size of RAM and would allow for easy transfer to Red Hat support for kernel engineer analysis.

Additional info:

Comment 4 Akira Imamura 2005-11-23 00:02:23 UTC

*** This bug has been marked as a duplicate of 168641 ***


Note You need to log in before you can comment on or make changes to this bug.