Bug 1704582 - [RFE] Detect when scap content profile has no rules
Summary: [RFE] Detect when scap content profile has no rules
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: SCAP Plugin
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Aditi Puntambekar
QA Contact: Jameer Pathan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-30 06:30 UTC by Ondřej Pražák
Modified: 2020-06-08 13:14 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-06-08 13:14:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 26802 Normal New Detect when scap content profile has no rules 2020-08-31 13:00:41 UTC

Description Ondřej Pražák 2019-04-30 06:30:24 UTC
Description of problem:
When importing profiles from scap file on proxy, all profiles are imported, but some of them may not contain any rules. When a profile with zero rules is used for scan, the resulting report has no results.

Empty report suggests something is wrong, but there is no indication that the profile has no rules and empty report is expected in this case.

Steps to Reproduce:
1. Set up RHEL7 policy with default profile for scan 
2. run scan, examine incoming reports

Actual results:
Incoming report will be empty and there is no indication why

Expected results:
Let users know they are using a profile with zero rules

Comment 3 Ondřej Pražák 2019-04-30 08:23:40 UTC
Related docs issue: https://bugzilla.redhat.com/show_bug.cgi?id=1668158

Comment 4 Ondřej Pražák 2019-05-16 08:29:07 UTC
Created redmine issue http://projects.theforeman.org/issues/26802 from this bug

Comment 5 Bryan Kearney 2019-11-05 20:46:08 UTC
Upstream bug assigned to apuntamb@redhat.com

Comment 6 Bryan Kearney 2020-05-01 14:22:46 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Red Hat Technical Support or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 7 Bryan Kearney 2020-06-08 13:14:04 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.