Bug 1704590 - [UPI on Baremetal] Clusteroperator "image-registry" is not present during installation
Summary: [UPI on Baremetal] Clusteroperator "image-registry" is not present during ins...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image Registry
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.1.0
Assignee: Alexey Gladkov
QA Contact: Wenjing Zheng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-30 07:25 UTC by weiwei jiang
Modified: 2019-06-04 10:48 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Clusteroperator is not created if an error has occurred. Consequence: Clusteroperator is not created sometimes. Fix: Create Clusteroperator even after error. Result: Clusteroperator is created.
Clone Of:
Environment:
Last Closed: 2019-06-04 10:48:18 UTC
Target Upstream Version:
adam.kaplan: needinfo-
adam.kaplan: needinfo-


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:48:24 UTC

Description weiwei jiang 2019-04-30 07:25:59 UTC
Description of problem:
➜  ~ oc get clusteroperators
NAME                                 VERSION                             AVAILABLE   PROGRESSING   DEGRADED   SINCE
authentication                       4.1.0-0.nightly-2019-04-25-121505   True        False         False      7m11s
cloud-credential                     4.1.0-0.nightly-2019-04-25-121505   True        False                    16m
cluster-autoscaler                   4.1.0-0.nightly-2019-04-25-121505   True        False                    17m
console                              4.1.0-0.nightly-2019-04-25-121505   True        False         False      8m50s
dns                                  4.1.0-0.nightly-2019-04-25-121505   True        False         False      16m
ingress                              4.1.0-0.nightly-2019-04-25-121505   True        False         False      10m
kube-apiserver                       4.1.0-0.nightly-2019-04-25-121505   True        False         False      14m
kube-controller-manager              4.1.0-0.nightly-2019-04-25-121505   True        False         False      13m
kube-scheduler                       4.1.0-0.nightly-2019-04-25-121505   True        False         False      14m
machine-api                          4.1.0-0.nightly-2019-04-25-121505   True        False                    17m
machine-config                       4.1.0-0.nightly-2019-04-25-121505   True        False         False      16m
marketplace                          4.1.0-0.nightly-2019-04-25-121505   True        False                    10m
monitoring                           4.1.0-0.nightly-2019-04-25-121505   True        False                    9m23s
network                              4.1.0-0.nightly-2019-04-25-121505   True        False         False      16m
node-tuning                          4.1.0-0.nightly-2019-04-25-121505   True        False         False      12m
openshift-apiserver                  4.1.0-0.nightly-2019-04-25-121505   True        False         False      11m
openshift-controller-manager         4.1.0-0.nightly-2019-04-25-121505   True        False         False      14m
openshift-samples                    4.1.0-0.nightly-2019-04-25-121505   True        False         False      9m19s
operator-lifecycle-manager           4.1.0-0.nightly-2019-04-25-121505   True        False                    16m
operator-lifecycle-manager-catalog   4.1.0-0.nightly-2019-04-25-121505   True        False                    16m
service-ca                           4.1.0-0.nightly-2019-04-25-121505   True        False         False      16m
service-catalog-apiserver            4.1.0-0.nightly-2019-04-25-121505   True        False         False      12m
service-catalog-controller-manager   4.1.0-0.nightly-2019-04-25-121505   True        False         False      12m
storage                              4.1.0-0.nightly-2019-04-25-121505   True        False                    10m
➜  ~ oc get clusterversion 
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.1.0-0.nightly-2019-04-25-121505   False       True          19m     Unable to apply 4.1.0-0.nightly-2019-04-25-121505: the cluster operator image-registry has not yet successfully rolled out
➜  ~ oc get pods -n openshift-image-registry 
NAME                                               READY   STATUS    RESTARTS   AGE
cluster-image-registry-operator-6956f5d566-chbj7   1/1     Running   0          8m50s


Version-Release number of selected component (if applicable):
4.1.0-0.nightly-2019-04-25-121505

How reproducible:
Always

Steps to Reproduce:
1. Install cluster with upi on baremetal way
2. Check if image-registry
3.

Actual results:
image-registry is not present, and this prevent the cluster to complete

Expected results:
image-registry should work well.

Additional info:
IPI on AWS with same payload image have no such issue.


workaround:
create a clusteroperator named image-registry by manual during installation
#> echo 'apiVersion: config.openshift.io/v1
kind: ClusterOperator
metadata:
 name: image-registry
spec: {}' | oc create -f -

Comment 1 Oleg Bulatov 2019-04-30 16:46:02 UTC
Please attach the operator's logs.

Comment 3 Alexey Gladkov 2019-05-02 14:28:01 UTC
What version of cluster-image-registry-operator image was used ?
(I need to known build tag/commit).

Comment 6 weiwei jiang 2019-05-07 07:45:25 UTC
Checked with following version, can not reproduce this issue move to verified.
oc get clusterversion                                      
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.1.0-0.nightly-2019-05-06-234425   True        False         21m     Cluster version is 4.1.0-0.nightly-2019-05-06-234425

Comment 8 errata-xmlrpc 2019-06-04 10:48:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.