Bug 17046 - many man pages don't escape troff codes when they should
many man pages don't escape troff codes when they should
Status: CLOSED DUPLICATE of bug 12840
Product: Red Hat Linux
Classification: Retired
Component: sh-utils (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: bero
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-28 13:25 EDT by deborah
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-30 07:40:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description deborah 2000-08-28 13:25:59 EDT
many of the man pages shipped with redhat 6.1 and 6.2 are buggy.  They do not escape the necessary output modification codes so the groff interpreting the pages reads the codes.  For example, look at the output of "man printf".  First of all, the codes exhibited in the page itself are interpreted, thus their listing is garbled.look at the section beneath the string "interpreted sequences are:".  Secondly, when you exit the manual page there are several errors on the screen:

<standard input>:44: a newline character is not allowed in an escape name
<standard input>:47: a newline character is not allowed in an escape name
<standard input>:56: cannot use newline as a starting delimiter
<standard input>:59: warning: numeric expression expected (got `N')

I have also noticed this behavior in the man page for echo.  

I couldn't find thisanywhere in the existing bugs.  this behavior doesn't exist in 5.x, but I have reproduced it on 6.x machines on multiple hardware platforms with multiple configurations.

-deborah
Comment 1 deborah 2000-08-28 13:36:36 EDT
Damn -- looks like my web browser dropped some info.  This is in man-pages, not in AfterStep, and for versions 6.x, not 4.2.  Sorry.

-deborah
Comment 2 Bernhard Rosenkraenzer 2000-08-28 13:44:23 EDT
Re-assigning to sh-utils (where the printf man page is coming from) and the
current version (man pages haven't changed in 7.0 betas).
Comment 3 Jeff Johnson 2001-01-06 07:27:16 EST

*** This bug has been marked as a duplicate of 12840 ***

Note You need to log in before you can comment on or make changes to this bug.