Bug 170467 - [RHEL3] [RFE] [ORACLE ESCALATION] pam_access requires a tty name
[RHEL3] [RFE] [ORACLE ESCALATION] pam_access requires a tty name
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: pam (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Jay Turner
:
Depends On: 168276
Blocks: 168429
  Show dependency treegraph
 
Reported: 2005-10-11 19:20 EDT by Tomas Mraz
Modified: 2015-01-07 19:10 EST (History)
7 users (show)

See Also:
Fixed In Version: RHBA-2006-0093
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-07 13:49:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Mraz 2005-10-11 19:20:20 EDT
+++ This bug was initially created as a clone of Bug #168276 +++

Escalated to Bugzilla from IssueTracker

-- Additional comment from tao@redhat.com on 2005-09-14 08:34 EST --
From User-Agent: XML-RPC

We've got an issue with redhat's pam_access module. This prevents a production
system from being able to run oracle 10 rac, which is required for a project
that is going into production now.



See this patch to debian:
http://readlist.com/lists/lists.debian.org/debian-user/4/22300.html



The oracle bug number is 4499311.



Thanks,



-Peter
This event sent from IssueTracker by laroche
 issue 79327

-- Additional comment from tmraz@redhat.com on 2005-09-23 05:22 EST --
Created an attachment (id=119178)
Proposed patch

This patch makes pam_access not fail when tty is unavailable and unavailable
tty will match rules with ALL.

This is currently planned to be included in the next update release if no
problems are found.
Comment 5 Jason McCormick 2005-11-11 14:11:54 EST
Is there a rawhide version or another build of this I can test?  I'm running
into this problem with VMware GSX's remote console.
Comment 6 Tomas Mraz 2005-11-14 03:02:38 EST
It is fixed in pam-0.80-13 in rawhide and latest FC-3 and FC-4 pam updates as well.
Comment 7 Jason McCormick 2005-11-17 09:41:24 EST
Where can I get pam-0.80-13 for AS4?  I looked at rawhide.redhat.com and can't
see where to get it. Probably missing somewhere obvious...
Comment 9 Jason McCormick 2005-11-30 17:43:34 EST
I backported the patch from 0.80 and rebuilt it from the 0.77 SRPM for AS4 and
this has worked flawlessly for me.
Comment 17 Red Hat Bugzilla 2006-03-07 13:49:22 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0093.html

Note You need to log in before you can comment on or make changes to this bug.