Bug 1704691 - ROOT gui is not working
Summary: ROOT gui is not working
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: root
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mattias Ellert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1709805 (view as bug list)
Depends On: 1708922
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-30 11:10 UTC by Martin Vala
Modified: 2019-05-30 13:19 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-23 17:48:13 UTC
Type: Bug


Attachments (Terms of Use)

Description Martin Vala 2019-04-30 11:10:22 UTC
Description of problem:
Problem running gui (for example TBrowser) in root when installed via dnf or rpm-ostree

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.
🔹[mvala@toolbox root]$ root 
root [0] new TBrowser
Error in <RootX11ErrorHandler>: GLXBadContext (XID: 52429168, XREQ: 150)
[xcb] Unknown sequence number while processing queue
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
root.exe: xcb_io.c:263: poll_for_event: Assertion `!xcb_xlib_threads_sequence_lost' failed.
🔹[mvala@toolbox root]$ 
2.
3.

Actual results:
Gui window is not shown

Expected results:
Gui should work

Additional info:
When i compiled root from source gui is working fine

Comment 1 Fedora Update System 2019-05-14 11:16:56 UTC
libAfterImage-1.20-21.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-37ba387bca

Comment 2 Fedora Update System 2019-05-14 11:17:05 UTC
libAfterImage-1.20-21.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-bedeb1af38

Comment 3 Fedora Update System 2019-05-14 11:17:14 UTC
libAfterImage-1.20-21.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-6389c91fe6

Comment 4 Fedora Update System 2019-05-14 11:17:22 UTC
libAfterImage-1.20-21.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-6a28a7fe8d

Comment 5 Fedora Update System 2019-05-14 11:17:31 UTC
libAfterImage-1.20-21.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-d4ddf39537

Comment 6 Mattias Ellert 2019-05-14 11:58:05 UTC
*** Bug 1709805 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2019-05-15 00:44:22 UTC
libAfterImage-1.20-21.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-37ba387bca

Comment 8 Fedora Update System 2019-05-15 00:53:04 UTC
libAfterImage-1.20-21.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-bedeb1af38

Comment 9 Fedora Update System 2019-05-15 00:58:16 UTC
libAfterImage-1.20-21.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-6a28a7fe8d

Comment 10 Fedora Update System 2019-05-15 07:25:46 UTC
libAfterImage-1.20-21.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-d4ddf39537

Comment 11 Martin Vala 2019-05-15 07:33:50 UTC
Problem is solved for me

Comment 12 Fedora Update System 2019-05-15 07:40:23 UTC
libAfterImage-1.20-21.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-6389c91fe6

Comment 13 Fedora Update System 2019-05-23 17:48:13 UTC
libAfterImage-1.20-21.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2019-05-23 18:27:30 UTC
libAfterImage-1.20-21.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2019-05-24 21:49:15 UTC
libAfterImage-1.20-21.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2019-05-30 12:50:12 UTC
libAfterImage-1.20-21.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2019-05-30 13:19:00 UTC
libAfterImage-1.20-21.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.