Bug 170482 - FC4 Disk Druid Default Partitioning Scheme Worst Possible
FC4 Disk Druid Default Partitioning Scheme Worst Possible
Status: CLOSED DUPLICATE of bug 150670
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-12 02:23 EDT by bob mckay
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-15 11:08:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bob mckay 2005-10-12 02:23:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/412.7 (KHTML, like Gecko) Safari/412.5

Description of problem:
Sorry, I realise that this probably isn't the right place for a Disk Druid problem, but there doesn't seem to 
be a correct place to put Disk Druid problems that I could find.

The default partition scheme Disk Druid gives under FC4 is the worst possible choice. Since the default is 
for logical partitions, and logical partitions are easy to expand but require extreme expertise to shrink, a 
scheme giving a conservative partition size to the home filesystem would be desirable. In fact, the default 
partition size is the vast bulk of available disk space, giving the user who accepts this choice virtually no 
flexibility to change it later.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install FC4 using the default partitioning scheme.
2.
3.
  

Actual Results:  Got the worst possible partitioning scheme under logical volume management, because subsequently 
changing it requires too much expertise (see discussion at http://www.linuxquestions.org/questions/
showthread.php?s=&threadid=337823&highlight=resize+lvm)

Expected Results:  The installation process should take one of two options:
.Best: install a conservative size home partition, and direct users who want to use a larger home partition 
to use the partition configuration tool (ie the default should be appropriate for most purposes; the current 
default is inappropriate for just about everyone)
.Second best: explain the consequences of using the default choice (i.e. inflexibility of the file system) 
before the user commits to it (a "do you really want to" bubble)

Additional info:
Comment 1 Jeremy Katz 2005-10-15 11:08:58 EDT

*** This bug has been marked as a duplicate of 150670 ***

Note You need to log in before you can comment on or make changes to this bug.