Bug 1704855 - Not able to upgrade to F30 because of lxqt-l10n being obsoleted
Summary: Not able to upgrade to F30 because of lxqt-l10n being obsoleted
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: liblxqt
Version: 30
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Zamir SUN
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-30 16:31 UTC by Peter Hull
Modified: 2019-05-14 00:59 UTC (History)
6 users (show)

Fixed In Version: liblxqt-0.14.1-1.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-14 00:59:10 UTC
Type: Bug


Attachments (Terms of Use)

Description Peter Hull 2019-04-30 16:31:37 UTC
Description of problem:
Not able to upgrade from FC29 to FC30. 

Version-Release number of selected component (if applicable):
0.13.0-1.fc29

How reproducible:
Always


Steps to Reproduce:
0. sudo -s
1. dnf --refresh upgrade
2. dnf system-upgrade download --releasever30

Actual results:
See error messages as follows,
Error: 
 Problem: package lxqt-l10n-0.13.0-1.fc29.noarch requires libfm-qt-l10n = 0.13.0-1.fc29, but none of the providers can be installed
  - libfm-qt-l10n-0.13.0-1.fc29.noarch does not belong to a distupgrade repository
  - problem with installed package lxqt-l10n-0.13.0-1.fc29.noarch
(try to add '--skip-broken' to skip uninstallable packages)


Expected results:
Downloads the upgraded files.


Additional info:

This is the Fedora LXQt spin.

Comment 1 Peter Hull 2019-05-01 12:25:32 UTC
Note: adding '--skip-broken' as suggested resulted in the same error message.

I believe lxqt-l10n has been obsoleted in the current version of LXQt so presumably this is why there is a problem with updating it. https://lxqt.org/release/2019/01/25/lxqt-0140/

Comment 2 Zamir SUN 2019-05-02 03:10:13 UTC
Sorry for the inconvenience. Upstream decide to separate lxqt-l10n into corresponding applications so we obsoleted it in Fedora correspondingly. However since I don't use lxqt-l10n so I did not notice this before.
You can try to uninstall lxqt-l10n before upgrade. And then install the *-l10n packages separately after the system got upgraded to Fedora 30. I've tested this workaround in a VM.

Comment 3 Peter Hull 2019-05-02 07:48:43 UTC
Thanks for the response. I am not in a hurry to upgrade so I can either:
* Try the workaround of uninstalling lxqt-l10n as you suggest
* Wait for a fix and test that (assuming you plan to fix it, of course)
Would either of these be more helpful to you in terms of verifying that things work?

Comment 4 Zamir SUN 2019-05-02 09:41:05 UTC
Thanks for the kind offer. It's up to you.

Just to let you know I will update LXQt to 0.14.1 in Fedora 30 and the fix will go along with this update, which means this will cost me some days.

Comment 5 Peter Hull 2019-05-02 13:09:55 UTC
I do appreciate that, thank you. I will wait for the update.

Comment 6 Zamir SUN 2019-05-02 14:49:32 UTC
I have reproduced this issue locally.
# dnf system-upgrade download --releasever=30
Before you continue ensure that your system is fully upgraded by running "dnf --refresh upgrade". Do you want to continue [y/N]: y
Fedora Modular 30 - x86_64                      4.3 kB/s | 4.6 kB     00:01    
Fedora Modular 30 - x86_64 - Updates            1.5 kB/s | 5.6 kB     00:03    
Fedora 30 - x86_64 - Updates                    5.9 kB/s | 5.8 kB     00:00    
Fedora 30 - x86_64                              4.7 kB/s | 4.7 kB     00:01    
Error: 
 Problem: package lxqt-l10n-0.13.0-1.fc29.noarch requires libfm-qt-l10n = 0.13.0-1.fc29, but none of the providers can be installed
  - libfm-qt-l10n-0.13.0-1.fc29.noarch does not belong to a distupgrade repository
  - problem with installed package lxqt-l10n-0.13.0-1.fc29.noarch
(try to add '--skip-broken' to skip uninstallable packages)

And the bug fix lands in my copr now works.

Dependencies resolved.
================================================================================
 Package                       Arch   Version                   Repo       Size
================================================================================
Upgrading:
 libfm-qt                      x86_64 0.14.1-1.fc30             zsun-lxqt 530 k
 libfm-qt-l10n                 x86_64 0.14.1-1.fc30             zsun-lxqt 138 k
 liblxqt                       x86_64 0.14.1-1.fc30             zsun-lxqt 110 k
 liblxqt-l10n                  x86_64 0.14.1-1.fc30             zsun-lxqt  50 k
     replacing  lxqt-l10n.noarch 0.13.0-1.fc29



I'll push them into Fedora later this week.

Comment 7 Zamir SUN 2019-05-04 11:25:49 UTC
Change component. Now liblxqt-l10n should obsolete lxqt-l10n to make upgrade work.

Comment 8 Fedora Update System 2019-05-04 11:27:49 UTC
lxqt-runner-0.14.1-1.fc30 lxqt-panel-0.14.1-1.fc30 qterminal-0.14.1-1.fc30 pcmanfm-qt-0.14.1-1.fc30 lxqt-sudo-0.14.1-1.fc30 lxqt-session-0.14.1-1.fc30 lxqt-powermanagement-0.14.1-1.fc30 lxqt-policykit-0.14.1-1.fc30 lxqt-openssh-askpass-0.14.1-1.fc30 lxqt-notificationd-0.14.1-1.fc30 lxqt-globalkeys-0.14.1-1.fc30 lxqt-config-0.14.1-1.fc30 lxqt-admin-0.14.1-1.fc30 lxqt-about-0.14.1-1.fc30 lximage-qt-0.14.1-1.fc30 qtermwidget-0.14.1-1.fc30 pavucontrol-qt-0.14.1-1.fc30 obconf-qt-0.14.1-1.fc30 libfm-qt-0.14.1-1.fc30 liblxqt-0.14.1-1.fc30 libqtxdg-3.3.1-1.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-0f27326965

Comment 9 Fedora Update System 2019-05-05 00:53:44 UTC
libfm-qt-0.14.1-1.fc30, liblxqt-0.14.1-1.fc30, libqtxdg-3.3.1-1.fc30, lximage-qt-0.14.1-1.fc30, lxqt-about-0.14.1-1.fc30, lxqt-admin-0.14.1-1.fc30, lxqt-config-0.14.1-1.fc30, lxqt-globalkeys-0.14.1-1.fc30, lxqt-notificationd-0.14.1-1.fc30, lxqt-openssh-askpass-0.14.1-1.fc30, lxqt-panel-0.14.1-1.fc30, lxqt-policykit-0.14.1-1.fc30, lxqt-powermanagement-0.14.1-1.fc30, lxqt-runner-0.14.1-1.fc30, lxqt-session-0.14.1-1.fc30, lxqt-sudo-0.14.1-1.fc30, obconf-qt-0.14.1-1.fc30, pavucontrol-qt-0.14.1-1.fc30, pcmanfm-qt-0.14.1-1.fc30, qterminal-0.14.1-1.fc30, qtermwidget-0.14.1-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-0f27326965

Comment 10 Peter Hull 2019-05-08 11:29:59 UTC
Using the instructions in QA:Updates_Testing I was able to upgrade to 30 with no problems.
Thanks.

Comment 11 Fedora Update System 2019-05-14 00:59:10 UTC
libfm-qt-0.14.1-1.fc30, liblxqt-0.14.1-1.fc30, libqtxdg-3.3.1-1.fc30, lximage-qt-0.14.1-1.fc30, lxqt-about-0.14.1-1.fc30, lxqt-admin-0.14.1-1.fc30, lxqt-config-0.14.1-1.fc30, lxqt-globalkeys-0.14.1-1.fc30, lxqt-notificationd-0.14.1-1.fc30, lxqt-openssh-askpass-0.14.1-1.fc30, lxqt-panel-0.14.1-1.fc30, lxqt-policykit-0.14.1-1.fc30, lxqt-powermanagement-0.14.1-1.fc30, lxqt-runner-0.14.1-1.fc30, lxqt-session-0.14.1-1.fc30, lxqt-sudo-0.14.1-1.fc30, obconf-qt-0.14.1-1.fc30, pavucontrol-qt-0.14.1-1.fc30, pcmanfm-qt-0.14.1-1.fc30, qterminal-0.14.1-1.fc30, qtermwidget-0.14.1-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.