Bug 170488 - "screen" support would be good
"screen" support would be good
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vlock (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-12 06:10 EDT by Need Real Name
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-14 08:19:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2005-10-12 06:10:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Epiphany/1.6.5

Description of problem:
vlock -a does not lock all screens, i.e. ^a^n will move to the password unprotected screen.

It would be nice if vlock warned users that it was running from within screen (screen has it's own locking function).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
x

Additional info:
Comment 1 Karel Zak 2005-10-13 06:00:41 EDT
  *** This tty is not a VC (virtual console). ***
  *** It may not be securely locked. ***

  This TTY is now locked.
  Please enter the password to unlock.
  root's Password:

Do you think that the sentence "It may not be securely locked." is not enough?
Well, I can add there some next extra message like "You're probably runnig
screen(1). Please, check screen documentation for correct locking.". But I think
the the actual warning is almost enough.
Comment 2 Need Real Name 2005-10-13 12:27:47 EDT
The message "it may not be securely locked" shows when you try to lock a virtual
console, but the docs say this message appears because virtual console locking
has been given less testing than real console locking.

When I run vlock from inside screen, the console is *definitely* not securely
locked - I can run ^AC to create a new console.

A screen specific warning would be good I think.
Comment 3 Karel Zak 2005-10-14 08:19:20 EDT
Done. Update to vlock-1.3-22.
Comment 4 Karel Zak 2005-10-14 08:20:22 EDT
Note that fixed in the development branch (FC5).
Comment 5 Need Real Name 2005-10-14 08:26:44 EDT
Thanks!

Note You need to log in before you can comment on or make changes to this bug.