Bug 1704971 - Gnome software use with Flatpak is broken
Summary: Gnome software use with Flatpak is broken
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-software
Version: 30
Hardware: x86_64
OS: Linux
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2019-04-30 22:48 UTC by Cetera
Modified: 2019-12-13 12:18 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2019-12-13 12:18:09 UTC
Type: Bug

Attachments (Terms of Use)
Empty application area (25.13 KB, image/png)
2019-04-30 22:48 UTC, Cetera
no flags Details
Blue icons instead of the real ones (134.86 KB, image/png)
2019-04-30 22:48 UTC, Cetera
no flags Details
Only already installed applications are shown (43.21 KB, image/png)
2019-04-30 22:57 UTC, Cetera
no flags Details

Description Cetera 2019-04-30 22:48:10 UTC
Created attachment 1560581 [details]
Empty application area

Description of problem:
gnome-software doesn't show available applications at all.
Installed applications are missing their icons (they only have the blue default one in gnome-software).

Version-Release number of selected component (if applicable):

How reproducible:
No idea. But it's always here. Deleting cache doesn't have any effect.

Comment 1 Cetera 2019-04-30 22:48:52 UTC
Created attachment 1560582 [details]
Blue icons instead of the real ones

Comment 2 Cetera 2019-04-30 22:57:36 UTC
Created attachment 1560585 [details]
Only already installed applications are shown

Comment 3 Cetera 2019-05-01 17:05:35 UTC
Only the snap extension works: when I install this extension, I can see the snaps with icons, proposed applications and so on.

Comment 4 Cetera 2019-05-01 23:25:49 UTC
Ok. Got it. This is a problem related to Flatpak.

To reproduce it:
- Install Flathub with this link: https://flatpak.org/setup/Fedora/
- Quit gnome-software.
- Type "pkcon refresh" in the terminal.
- Re-open gnome-sofware.
- Oh... Everything is broken!

Comment 5 Petr Schindler 2019-05-09 06:34:18 UTC
I followed the steps from comment 4 on clean f30 installation. The gnome-software still shows application so my guess is that the problem is elsewhere. Just for reference - probably the same bug with some logs is here: https://bugzilla.redhat.com/show_bug.cgi?id=1702551

Comment 6 Cetera 2019-05-12 12:05:26 UTC
I tried to reproduce it installing Flatpak again. I thought the problem had disappeared, as it worked perfectly for 2 days.
But I got it again after gnome 3.32.2 update.

So I guess that to observe it, you need to:
- install Flatpak, enable Flathub
- then reinit something in gnome-software (I don't know what; maybe deleting the .cache?)

Comment 7 Cetera 2019-05-12 12:22:31 UTC
And then, after a "sudo flatpak remote-delete flathub" (because removing flathub through gnome-software interface doesn't work...) and reinstalling gnome-software, everything is back. :)

Note You need to log in before you can comment on or make changes to this bug.