Bug 1704973 - Overcloud deployment on pre-deployed server fails when network-scripts package is not installed
Summary: Overcloud deployment on pre-deployed server fails when network-scripts packag...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: beta
: 15.0 (Stein)
Assignee: Adriano Petrich
QA Contact: Sasha Smolyak
URL:
Whiteboard:
Depends On: 1734172
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-30 22:52 UTC by Marius Cornea
Modified: 2019-10-28 07:57 UTC (History)
7 users (show)

Fixed In Version: openstack-tripleo-common-10.7.1-0.20190520133901.eeee6fb.el8ost.noarch
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:21:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 656705 0 'None' MERGED bootstrap: install network-scripts if EL8 2020-06-19 06:09:02 UTC
OpenStack gerrit 657448 0 'None' MERGED bootstrap: install network-scripts if EL8 2020-06-19 06:09:01 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:21:53 UTC

Description Marius Cornea 2019-04-30 22:52:18 UTC
Description of problem:
Overcloud deployment on pre-deployed server fails when network-scripts package is not installed:

TASK [tripleo-bootstrap : Ensure network service is enabled and started] *******
Tuesday 30 April 2019  22:46:32 +0000 (0:00:00.593)       0:01:35.183 ********* 
fatal: [compute-1]: FAILED! => {"changed": false, "msg": "Could not find the requested service network: host"}
fatal: [compute-0]: FAILED! => {"changed": false, "msg": "Could not find the requested service network: host"}
fatal: [controller-0]: FAILED! => {"changed": false, "msg": "Could not find the requested service network: host"}
fatal: [ceph-1]: FAILED! => {"changed": false, "msg": "Could not find the requested service network: host"}
fatal: [controller-1]: FAILED! => {"changed": false, "msg": "Could not find the requested service network: host"}
fatal: [ceph-2]: FAILED! => {"changed": false, "msg": "Could not find the requested service network: host"}
fatal: [ceph-0]: FAILED! => {"changed": false, "msg": "Could not find the requested service network: host"}
fatal: [controller-2]: FAILED! => {"changed": false, "msg": "Could not find the requested service network: host"}

NO MORE HOSTS LEFT *************************************************************

PLAY RECAP *********************************************************************
ceph-0                     : ok=6    changed=3    unreachable=0    failed=1    skipped=0    rescued=0    ignored=0   
ceph-1                     : ok=6    changed=3    unreachable=0    failed=1    skipped=0    rescued=0    ignored=0   
ceph-2                     : ok=6    changed=3    unreachable=0    failed=1    skipped=0    rescued=0    ignored=0   
compute-0                  : ok=6    changed=3    unreachable=0    failed=1    skipped=0    rescued=0    ignored=0   
compute-1                  : ok=6    changed=3    unreachable=0    failed=1    skipped=0    rescued=0    ignored=0   
controller-0               : ok=6    changed=3    unreachable=0    failed=1    skipped=0    rescued=0    ignored=0   
controller-1               : ok=6    changed=3    unreachable=0    failed=1    skipped=0    rescued=0    ignored=0   
controller-2               : ok=6    changed=3    unreachable=0    failed=1    skipped=0    rescued=0    ignored=0   
undercloud                 : ok=3    changed=0    unreachable=0    failed=0    skipped=0    rescued=0    ignored=0   


Version-Release number of selected component (if applicable):
15  -p RHOS_TRUNK-15.0-RHEL-8-20190423.n.1

How reproducible:
100%

Steps to Reproduce:
1. Deploy overcloud on pre-deployed servers using RHEL8 cloud image

Actual results:
TASK [tripleo-bootstrap : Ensure network service is enabled and started]  fails because network-scripts package is not installed.

Expected results:
No failure

Additional info:

Comment 9 errata-xmlrpc 2019-09-21 11:21:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.