Bug 1705217 - Cant install CP2K at all
Summary: Cant install CP2K at all
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cp2k
Version: 30
Hardware: All
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Dominik 'Rathann' Mierzejewski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-01 18:47 UTC by Henrique C. S. Junior
Modified: 2019-08-19 01:01 UTC (History)
3 users (show)

Fixed In Version: cp2k-6.1-4.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-19 01:01:59 UTC
Type: Bug


Attachments (Terms of Use)

Description Henrique C. S. Junior 2019-05-01 18:47:54 UTC
DNF fails to install CP2K due to broken dependencies:

 henrique  (e) base  ~  sudo dnf install cp2k-openmpi --skip-broken -y
Last metadata expiration check: 0:13:27 ago on Wed 01 May 2019 03:29:41 PM -03.
Dependencies resolved.

 Problem: package cp2k-openmpi-6.1-1.fc29.x86_64 requires libmpi.so.20()(64bit)(openmpi-x86_64), but none of the providers can be installed
  - package cp2k-openmpi-6.1-1.fc29.x86_64 requires libmpi_mpifh.so.20()(64bit)(openmpi-x86_64), but none of the providers can be installed
  - package cp2k-openmpi-6.1-1.fc29.x86_64 requires libmpi_usempi_ignore_tkr.so.20()(64bit)(openmpi-x86_64), but none of the providers can be installed
  - package cp2k-openmpi-6.1-1.fc29.x86_64 requires libmpi_usempif08.so.20()(64bit)(openmpi-x86_64), but none of the providers can be installed
  - conflicting requests
  - package openmpi-2.1.6-0.1.rc1.module_2624+29a0dad4.x86_64 is excluded
=========================================================================================================================================================================
 Package                                     Architecture                          Version                                   Repository                             Size
=========================================================================================================================================================================
Skipping packages with broken dependencies:
 cp2k-openmpi                                x86_64                                6.1-1.fc29                                fedora                                 17 M

Transaction Summary
=========================================================================================================================================================================
Skip  1 Package

Nothing to do.
Complete!

Comment 1 Dominik 'Rathann' Mierzejewski 2019-05-06 08:16:06 UTC
Cannot reproduce:
# dnf install cp2k-openmpi
Last metadata expiration check: 0:14:51 ago on Mon 06 May 2019 09:58:43 CEST.
Dependencies resolved.
========================================================================================================================
 Package                       Architecture       Version                                     Repository           Size
========================================================================================================================
Installing:
 cp2k-openmpi                  x86_64             6.1-1.fc29                                  fedora               17 M
Installing dependencies:
 Lmod                          x86_64             7.8.9-1.fc29                                updates             218 k
 hwloc-libs                    x86_64             1.11.12-1.fc29                              updates             1.6 M
 libxc                         x86_64             4.3.3-1.fc29                                updates             2.4 M
 lua-lpeg                      x86_64             1.0.1-10.fc29                               updates              63 k
 papi-libs                     x86_64             5.6.0-8.fc29                                updates             146 k
 blacs-common                  x86_64             2.0.2-26.fc29                               fedora               13 k
 blacs-openmpi                 x86_64             2.0.2-26.fc29                               fedora               57 k
 blas                          x86_64             3.8.0-10.fc29                               fedora              418 k
 cp2k-common                   x86_64             6.1-1.fc29                                  fedora               21 M
 elpa-common                   noarch             2017.05.003-3.fc29                          fedora               26 k
 elpa-openmpi                  x86_64             2017.05.003-3.fc29                          fedora              458 k
 infinipath-psm                x86_64             3.3-22_g4abbc60_open.6.fc29.1               fedora              196 k
 lapack                        x86_64             3.8.0-10.fc29                               fedora              8.6 M
 libderiv                      x86_64             1.2.1-7.fc29                                fedora               11 M
 libfabric                     x86_64             1.6.1-2.fc29                                fedora              536 k
 libint                        x86_64             1.2.1-7.fc29                                fedora               33 M
 libpfm                        x86_64             4.10.1-5.fc29                               fedora              296 k
 libpsm2                       x86_64             10.3.58-2.fc29                              fedora              192 k
 libxsmm                       x86_64             1.9-3.fc29                                  fedora              758 k
 lua-filesystem                x86_64             1.6.3-9.fc29                                fedora               32 k
 lua-json                      noarch             1.3.2-10.fc29                               fedora               26 k
 lua-term                      x86_64             0.07-7.fc29                                 fedora               15 k
 munge                         x86_64             0.5.13-2.fc29                               fedora              105 k
 munge-libs                    x86_64             0.5.13-2.fc29                               fedora               39 k
 openmpi                       x86_64             2.1.1-14.fc29                               fedora              2.6 M
 opensm-libs                   x86_64             3.3.20-9.fc29                               fedora               67 k
 scalapack-common              x86_64             2.0.2-26.fc29                               fedora               11 k
 scalapack-openmpi             x86_64             2.0.2-26.fc29                               fedora              1.7 M
 tcl                           x86_64             1:8.6.8-2.fc29                              fedora              1.1 M
 torque-libs                   x86_64             4.2.10-18.fc29                              fedora              129 k

Transaction Summary
========================================================================================================================
Install  31 Packages

Total download size: 104 M
Installed size: 444 M
Is this ok [y/N]: N
Operation aborted.

Your error message suggests you have some kind of openmpi module installed. Please disable/uninstall it.

Comment 2 Henrique C. S. Junior 2019-05-06 13:45:54 UTC
Hello, thanks for taking a look at this.
I have not activated the modularity on my Fedora. From your output it seems that you're running F29, right? The problem is happening in F30.
It seems that the default openmpi is now 3.1.3-2.fc30 instead of 2.1.x. I believe thats the source of error.
As I can see, using modularity we can now use several openmpi but, because I do not had the time to dig into it I'm just using default configurations on my system.

Comment 3 Dominik 'Rathann' Mierzejewski 2019-05-07 12:20:03 UTC
Sorry, I didn't notice it was for F30. I didn't have time to take good care of cp2k lately and it didn't rebuild correctly on F30, so the F29 version is in the repos. I still don't have much free time to take care of this quickly, sorry.

Comment 4 Henrique C. S. Junior 2019-05-10 13:53:07 UTC
Dear Dominik, to help with this bug I have contacted the upstream and opened an issue here: https://github.com/cp2k/cp2k/issues/348

The developer seems to have found a missing -fopenmp.
As soon as possible I'll take a look at the .spec, but since I only know the basics of programming I'm not sure that I can be of much help.

Comment 5 Henrique C. S. Junior 2019-05-11 20:00:58 UTC
Looks like the problem is on CP2Ks side and they are into it.

Comment 6 Dominik 'Rathann' Mierzejewski 2019-08-10 14:02:26 UTC
No, the problem was actually in the Fedora package and I've just fixed it. New builds are in progress:
https://koji.fedoraproject.org/koji/taskinfo?taskID=36908771
I'll submit an update as soon as they're done.

Comment 7 Fedora Update System 2019-08-10 17:36:28 UTC
FEDORA-2019-a035f6245d has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-a035f6245d

Comment 8 Fedora Update System 2019-08-11 02:20:25 UTC
cp2k-6.1-4.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-a035f6245d

Comment 9 Fedora Update System 2019-08-19 01:01:59 UTC
cp2k-6.1-4.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.