Bug 1705391 - python-glyphsLib FTBFS with Python 3.8
Summary: python-glyphsLib FTBFS with Python 3.8
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-glyphsLib
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Athos Ribeiro
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PYTHON38 1731532
TreeView+ depends on / blocked
 
Reported: 2019-05-02 08:48 UTC by Miro Hrončok
Modified: 2019-09-10 18:25 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-10 18:25:48 UTC
Type: Bug


Attachments (Terms of Use)
Full log from Copr (159.78 KB, text/plain)
2019-05-02 08:48 UTC, Miro Hrončok
no flags Details

Description Miro Hrončok 2019-05-02 08:48:44 UTC
Created attachment 1561419 [details]
Full log from Copr

python-glyphsLib 2.2.1-8.fc31 fails %check on Python 3.8:

E   AssertionError: *.designspace file is different from expected
----------------------------- Captured stderr call -----------------------------
--- /builddir/build/BUILD/glyphsLib-2.2.1/tests/data/DesignspaceTestBasic.designspace
+++ <generated>
@@ -1,7 +1,7 @@
 <?xml version='1.0' encoding='utf-8'?>
 <designspace format="3">
     <axes>
-        <axis default="400.0" maximum="900.0" minimum="400.0" name="weight" tag="wght">
+        <axis name="weight" tag="wght" minimum="400.0" maximum="900.0" default="400.0">
             <map input="400.0" output="90" />
             <map input="600.0" output="128" />
             <map input="700.0" output="151" />
@@ -10,7 +10,7 @@
         </axis>
     </axes>
     <sources>
-        <source familyname="DesignspaceTest Basic" filename="DesignspaceTestBasic-Regular.ufo" name="DesignspaceTest Basic Regular" stylename="Regular">
+        <source filename="DesignspaceTestBasic-Regular.ufo" name="DesignspaceTest Basic Regular" familyname="DesignspaceTest Basic" stylename="Regular">
...

(Full log attached.)

It's caused by https://bugs.python.org/issue34160 change.

XML attributes are no longer sorted, but they preserve dict order.

IF the package won't build with Python 3.8, it will be non-instalable on Fedora 31 once we make the switch.

Comment 1 Miro Hrončok 2019-07-10 10:07:08 UTC
Please respond.

Comment 2 Victor Stinner 2019-07-15 10:19:45 UTC
You can find a recipe to sort attributes at: https://bugs.python.org/issue34160#msg338102

Comment 3 Athos Ribeiro 2019-07-26 08:52:50 UTC
On it, sorry for the delay here :)

Comment 4 Athos Ribeiro 2019-07-28 15:06:12 UTC
Updated the package to v4.0.0 (rawhide only).

https://koji.fedoraproject.org/koji/taskinfo?taskID=36628948

I had to drop %check due to a couple missing test dependencies. Upstream test suite does run fine against python 3.8

Comment 5 Ben Cotton 2019-08-13 16:57:40 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 6 Ben Cotton 2019-08-13 18:36:59 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 7 Miro Hrončok 2019-08-14 22:24:08 UTC
The coordinated rebuild of Python 3.8 has started in the `f32-python` side tag.

If you figure out how to rebuild this package, please don't rebuild it in regular rawhide, but use the side tag instead:

    on branch master:
    $ fedpkg build --target=f32-python

To wait for a build to show up in the side tag, do:

    $ koji wait-repo f32-python --build=<nvr>

Where <nvr> is name-version-release of the source package, e.g. python-foo-1.1-2.fc32.

An updated mock config is posted at:
http://copr.fedorainfracloud.org/coprs/g/python/python3.8/

Note that it will take a while before the essential packages are rebuilt, so don't expect all your dependencies to be available right away.

Thanks. Let us know if you need up to date info, or if you have any questions.



PS this message is mass posted to all the bugs that block the PYTHON38 bug. If this is also a Fedora 31 FTBFS bug and you manage to fix it, you can do a f31 build as usual:

    on branch f31:
    $ fedpkg build

Comment 8 Miro Hrončok 2019-08-21 16:34:23 UTC
The f32-python side tag has been merged. In order to rebuild the package, do it in regular rawhide, but please wait until python3-3.8 is tagged:

  $ koji wait-repo f32-build --build python3-3.8.0~b3-3.fc32


If your built already started in f32-python, after it is finished, please tag it to rawhide with:

  $ koji tag-build f32-pending <nvr>

For example:

  $ koji tag-build f32-pending libreoffice-6.3.0.4-3.fc32

Thanks!

(This comment is mass posted to all bugzillas blocking the PYTHON38 tracking bug.)

Comment 9 Miro Hrončok 2019-08-21 17:28:58 UTC
(Python 3.8 has landed in the rawhide buildroot.)

Comment 10 Miro Hrončok 2019-09-10 18:25:48 UTC
This was rebuild with Python 3.8 and I'm closing it in bulk.

In case you wanted to keep this bugzilla open because the fix is not ideal, please reopen. Thanks.


Note You need to log in before you can comment on or make changes to this bug.