Bug 170541 - Installer doesn't detect onboard SATA controller (in fact, doesn't detect AMD 8131 and AMD 8111 controller)
Installer doesn't detect onboard SATA controller (in fact, doesn't detect AMD...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: David Milburn
Brian Brock
http://www.uwsg.iu.edu/hypermail/linu...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-12 14:02 EDT by Eric Laflamme
Modified: 2009-07-29 12:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-29 12:08:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Laflamme 2005-10-12 14:02:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
Problem on AMD dual core IBM 6217 workstation 
=======================================================
When installing Redhat 4.0 Update 2 64bits on the workstation, the SATA harddrive (ie the SATA controller) is not detected by the installer.  If I replace the SATA drive with a SCSI drive, it works and the installation is working.

After the installation (with the SCSI drive), if I run "lspci", EDI/Ethernet/FireWire/USB/SATA/Audio/etc Controllers are not detected (all in the AMD 8111 ship).

At the end is the result of "lspci".


I downloaded the kernel 2.6.12.1 from kernel.org.  In the change log, there's a fix with the AMD 8131 controller.  With this kernel installed, the hardware is detected correctly.

Also, there's no problem with Redhat3 Update 5, 32bits and 64bits, with the same workstation.



eric


====lspci output===

80:00.0 Memory controller: nVidia Corporation CK804 Memory Controller (rev a3)
80:01.0 Memory controller: nVidia Corporation CK804 Memory Controller (rev a3)
80:0d.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
80:0e.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
81:00.0 PCI bridge: NEC Corporation: Unknown device 0125 (rev 03)
81:00.1 PCI bridge: NEC Corporation: Unknown device 0125 (rev 03)
84:04.0 SCSI storage controller: Adaptec AIC-7902B U320 (rev 10)
84:04.1 SCSI storage controller: Adaptec AIC-7902B U320 (rev 10)
85:00.0 VGA compatible controller: nVidia Corporation: Unknown device 009d (rev a1)




Version-Release number of selected component (if applicable):
Redhat 4.0 Update2, kernel 2.6.9-22smp

How reproducible:
Always

Steps to Reproduce:
1. install Redhat4 Update2
2. Sata drive is not detected
3.
  

Additional info:

IBM 6217 workstation, dual core, 4G Memory, SATA drive, Nvidia graphics card.
Comment 1 Jason Baron 2005-10-12 14:33:57 EDT
is it possible to be more specific about which 'change' you are referencing? thanks.
Comment 2 Eric Laflamme 2005-10-12 16:15:33 EDT
Following the change log about the AMD 8131 controller.  I don`t know yet if 
it is only this change in the kernel 2.6.12.1 that looks to fix the problem.




in ftp://ftp.kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.12

    [PATCH] PCI: MSI functionality broken on Serverworks GC chipset
    
    MSI functionality is broken on the GC_LE x86 chipset that Serverworks
    developed and that is being used in various platforms today. Broadcom is
    going to push out to the kernel MSI enabled Gigabit drivers (in the very
    near future), and we would like to make sure that MSI does not get
    enabled on any platforms using the GC_LE chipset (device id 0x17).
    Following the AMD 8131 example, I am including a patch to disable MSI
    functionality when a GCNB_LE is detected. Please let me know if there
    are any issues with this. This is a permanent fix for this chipset, as
    the hardware will not be updated.
Comment 3 Eric Laflamme 2005-10-12 16:19:45 EDT
can you change the priority to high? I'm not able to do it.  
Current release of products are using the IBM 6217 dual core with Redhat3 
Update5, but we are moving to Redhat 4,  and we need this workstation working,


thanks a lot
eric
Comment 4 Brian Maly 2005-10-17 10:39:35 EDT
setting priority to high.

looks like some PCI updates might be needed here for RHEL4

Is this also a problem on i386 (in addition to x86_64)?

Comment 5 Eric Laflamme 2005-10-17 11:00:24 EDT
This morning I did some tests on an IBM6217 AMD SingleCore, both in 32bits and
64bits.  Both doesn't work. 

When I try to install Redhat4 Update2 32bits, after it try to probe aic79xx
hardware, the workstation freeze.  In 64bits, anaconda doesn't freeze, but give
me an error that no harddrive is detected.
Comment 6 Eric Laflamme 2005-10-25 21:12:08 EDT
I tryed today to start the add "acpi=off" at the boot prompt before starting 
anaconda.  The installation looks to work.  I will do other test tomorrow to 
see the stability of the IBM 6217 with acpi turned off.

Those acpi=off will affect performance, stability, etc, on the workstation?


thanks
Comment 7 Brian Maly 2006-12-15 15:24:33 EST
With logging set to verbose for kern.* in /etc/syslog.conf, do you get a "MSI
quirk detected" message in /var/log/dmesg? The quirk workaround for this is
exists in RHEL4, but slightly different than upstream. 

 
Comment 8 Brian Maly 2008-09-25 03:04:03 EDT
Can we debug this problem a bit further so as to resolve this in the next release? 

With the 2.6.12.1 was there a "MSI quirk detected" message in /var/log/dmesg? I can work out a test patch (or post a patched kernel) if the reporter of this bug is willing to test it on the affected hardware.
Comment 10 David Milburn 2009-07-29 12:08:39 EDT
Closing this out, please re-open if this is reproducible on RHEL4 U8.

Note You need to log in before you can comment on or make changes to this bug.