Bug 170545 - kernel_lock() problem through NFS mount
Summary: kernel_lock() problem through NFS mount
Status: CLOSED DUPLICATE of bug 167192
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Steve Dickson
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-10-12 18:19 UTC by Linda Wang
Modified: 2007-11-30 22:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-20 14:24:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backport of the entire NFS locking changes from 2.6.11 (4.12 KB, patch)
2005-10-13 02:24 UTC, Larry Woodman
no flags Details | Diff

Description Linda Wang 2005-10-12 18:19:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050512 Red Hat/1.0.4-1.4.1 Firefox/1.0.4

Description of problem:
We have discovered a problem where the kernel lock is still being held by a process
when it returns to user mode.  This results in other processes that are in the kernel
and want the kernel lock spinning inside of lock_kernel() and reacquire_kernel_lock()
even though the real lock holder is no longer in the kernel.

Version-Release number of selected component (if applicable):
kernel-2.6.9

How reproducible:
Always

Steps to Reproduce:
1.install RHEL4
2.mount a nfs filesystem
3.unlock a nfs mounted file
  

Actual Results:  all sorts of weird behavior happens with kernel lock held and going to user space.. espeically on SMP systems, you can notice the slowness of the system since it renders other cpus useless during swapping to user space.

Expected Results:  On smp kernel, there shouldn't be any slowness when a cpu goes into user space.

Additional info:

Comment 1 Linda Wang 2005-10-12 19:00:32 UTC
*** Bug 170546 has been marked as a duplicate of this bug. ***

Comment 2 Larry Woodman 2005-10-13 02:24:32 UTC
Created attachment 119871 [details]
Backport of the entire NFS locking changes from 2.6.11

I think we should include the entire NFS locking code from 2.6.11.  This fixes
several known problems including exiting the kernel with the kernel_lock still
held.

Larry Woodman

Comment 4 Steve Dickson 2005-10-20 14:24:24 UTC

*** This bug has been marked as a duplicate of 167192 ***


Note You need to log in before you can comment on or make changes to this bug.