Bug 1705492 - oc adm must-gather command stuck indefinitely
Summary: oc adm must-gather command stuck indefinitely
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.1.z
Assignee: Luis Sanchez
QA Contact: zhou ying
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-02 12:08 UTC by rushil
Modified: 2019-11-08 04:21 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-04 09:01:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:1635 None None None 2019-07-04 09:01:33 UTC

Description rushil 2019-05-02 12:08:25 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
VERY

Steps to Reproduce:
1. Login to openshift 4.1 cluster
2. run oc adm must-gather
3.

Actual results:
Stuck at this point :-
clusterrolebinding.rbac.authorization.k8s.io/must-gather-j67w2 created

Expected results:
Must finish with expected result which is to launch a pod in a temporary namespace on your cluster that gathers debugging information, using a
copy of the active client config context, and then downloads the gathered information.

Additional info:

Comment 1 Luis Sanchez 2019-05-02 18:59:41 UTC
oc adm must-gather can take a long time to run.

Try examining the pod's logs in a new terminal. For example:

# get name of must-gather pod:
$ oc get -n openshift-must-gather-xxxxx pod

# tail the gather container's logs:
$ oc -n openshift-must-gather-xxxxx log must-gather-xxxxx -c gather --follow

Comment 2 Eric Rich 2019-06-05 15:53:54 UTC
based on https://github.com/openshift/origin/pull/22829 moving to modified.

Comment 6 Eric Paris 2019-07-02 22:40:44 UTC
https://github.com/openshift/origin/pull/23036

Comment 10 zhou ying 2019-07-03 06:24:48 UTC
Confirmed with latest version : 
[root@dhcp-140-138 ose]# oc version --short
Client Version: v4.1.4
Server Version: v1.13.4+c3b23cb

Can't reproduce the issue. 

Will verify this when bugs ON-QA.

Comment 14 errata-xmlrpc 2019-07-04 09:01:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1635


Note You need to log in before you can comment on or make changes to this bug.