Bug 170552 (rhel4dmloadbal) - kernel dm multipath: Dynamic Load balancing
Summary: kernel dm multipath: Dynamic Load balancing
Status: CLOSED WONTFIX
Alias: rhel4dmloadbal
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 4.7
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Alasdair Kergon
QA Contact: Bill Peck
URL:
Whiteboard:
Keywords: FutureFeature
: 180435 184134 (view as bug list)
Depends On: 245197
Blocks: 176344 185133 200229 232471 232479 245198
TreeView+ depends on / blocked
 
Reported: 2005-10-12 20:03 UTC by Issue Tracker
Modified: 2018-11-14 18:19 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-07 21:03:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Issue Tracker 2005-10-12 20:03:50 UTC
Escalated to Bugzilla from IssueTracker

Comment 1 Rob Kenna 2005-10-12 20:06:13 UTC
This is an improvement on round-robin where loading of the paths is used to
dynamically balance I/O's

Comment 4 Alasdair Kergon 2005-10-21 14:07:44 UTC
A short patch has been submitted by Stefan Bader which does this.

It needs reviewing, checking for adverse interaction with iostats patches,
checking for performance issues when the feature is not being used, might have
kABI impact etc.

Possible for U3 subject to review.


Comment 6 Alasdair Kergon 2005-12-09 15:05:29 UTC
Missed U3 so now U4.

Comment 9 Alasdair Kergon 2006-03-03 18:22:43 UTC
*** Bug 180435 has been marked as a duplicate of this bug. ***

Comment 10 Alasdair Kergon 2006-03-06 19:46:18 UTC
*** Bug 184134 has been marked as a duplicate of this bug. ***

Comment 14 David Lawrence 2006-04-18 20:09:19 UTC
NEEDINFO_ENG has been deprecated in favor of NEEDINFO or ASSIGNED. Changing
status to ASSIGNED for ENG review.

Comment 17 Rob Kenna 2006-07-20 18:12:49 UTC
I think this needs to be targeted for 5.1

Comment 19 Daniel Riek 2006-08-11 18:30:18 UTC
At least it is not a 4.5 topic. Moving to 4.6 for now. Not sure if we shouldn't
jsut keep that to 5?

Comment 20 Rob Kenna 2007-03-20 15:39:53 UTC
This consistently arises as a customer request.  Still worth having in 4.6

Comment 23 Larry Troan 2007-07-15 18:50:23 UTC
Scoping work effort. Holding off devel ACK until complete.

Comment 24 Peter Martuccelli 2007-07-31 14:35:19 UTC
Too late for R4.6, moving out to R4.7.

Comment 26 Rob Kenna 2007-07-31 15:22:01 UTC
Moving to RHEL 5.2

Comment 27 Larry Troan 2007-08-16 19:13:17 UTC
ARG! 

Rob, the bugzilla for this function in RHEL5 is bug 199767. If this only being
considered for RHEL5, just close this bug as WONTFIX and take up the discussion
in  the other bug...

Comment 28 Sharon Lightcap 2007-08-27 15:35:55 UTC
Can someone at Red Hat please clarify which releases are being considered for  
addressing this problem? This is important for us to know for this Bugzilla
(170552) and also 199767.

Comment 29 Andrius Benokraitis 2007-08-27 17:50:04 UTC
Resetting for 4.7 consideration, as it already states in the Version field,
unless Rob you have other comments.

Comment 30 Issue Tracker 2007-08-29 17:15:38 UTC
Unisys is giving up on getting changes into RHEL4 in favor of focusing on
RHEL5 

Internal Status set to 'Resolved'
Status set to: Closed by Client
Resolution set to: 'Rejected'

This event sent from IssueTracker by dwa 
 issue 98463

Comment 31 Rob Kenna 2007-09-07 21:03:53 UTC
Moved to RHEL 5.2 as bug 199767. Closed WONTFIX


Note You need to log in before you can comment on or make changes to this bug.