Bug 1705606 - Idle - Session setup failed: NT_STATUS_ACCESS_DENIED
Summary: Idle - Session setup failed: NT_STATUS_ACCESS_DENIED
Keywords:
Status: CLOSED DUPLICATE of bug 1700791
Alias: None
Product: Fedora
Classification: Fedora
Component: samba
Version: 30
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Guenther Deschner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-02 14:57 UTC by Luca Giuzzi
Modified: 2019-05-13 10:21 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-13 10:21:17 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github apple cups issues 5573 None None None 2019-05-05 10:55:44 UTC

Description Luca Giuzzi 2019-05-02 14:57:06 UTC
Description of problem:

I am unable to print on a system shared via samba
(it is actually a network printer)

Version-Release number of selected component (if applicable):

cups-2.2.11-2.fc30.x86_64
samba-client-4.10.2-0.fc30.x86_64

How reproducible:

Always

Steps to Reproduce:
1. Redefine the printer
2. Try to print a file
3. Printing fails with: NT_STATUS_ACCESS_DENIED

Actual results:
Printing does not work

Expected results:
Printing works

Additional info:
./smb smb://user:passwd@domain/ip/Queue 1 2 3 4
actually authenticates the queue.

Comment 1 Luca Giuzzi 2019-05-02 14:58:50 UTC
Incidentally: the relevant stanza in printers.conf (with details removed) is

<DefaultPrinter Follow_Me>
UUID urn:uuid:d078ec2a-ab2b-3052-7626-bea8e5436c6d
AuthInfoRequired negotiate
Info Follow_Me
Location Unibs
MakeModel Canon iR-ADV C5535/5540 PPD
DeviceURI smb://user:passwd@domain/ip/FollowMe_Dominio
State Idle
StateTime 1556807635
ConfigTime 1556807628
Type 8433884
Accepting Yes
Shared No
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
ErrorPolicy stop-printer
</DefaultPrinter>

Comment 2 Luca Giuzzi 2019-05-08 12:39:15 UTC
Another point is that no matter what I write in printers.conf, but upon attempting to print a document the file is rewritten
with AuthInfoRequired negotiate (even if I explicitly wrote AuthInfoRequired None).
Also, the prompt I get from gnome has no field to insert a password to authenticate (but it should not request to authenticate).

Comment 3 Zdenek Dohnal 2019-05-13 09:55:04 UTC
Hi Luca!

thank you for reporting the issue! CUPS upstream ticket indicates it should be fixed in samba.

Comment 4 Andreas Schneider 2019-05-13 10:21:17 UTC

*** This bug has been marked as a duplicate of bug 1700791 ***


Note You need to log in before you can comment on or make changes to this bug.