Bug 1705635 - glibc: glibc `locale -a` output does not exactly match between locale-archive and langpacks.
Summary: glibc: glibc `locale -a` output does not exactly match between locale-archive...
Status: CLOSED DUPLICATE of bug 1326470
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Carlos O'Donell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks: 1627016
TreeView+ depends on / blocked
 
Reported: 2019-05-02 16:02 UTC by Carlos O'Donell
Modified: 2019-05-03 07:34 UTC (History)
15 users (show)

(edit)
Clone Of: 1627016
(edit)
Last Closed: 2019-05-03 07:34:17 UTC


Attachments (Terms of Use)

Description Carlos O'Donell 2019-05-02 16:02:09 UTC
Description of problem:
1. dnf install  glibc-all-langpacks 
2. locale -a|grep mr
   mr_IN
   mr_IN.utf8

1. dnf remove glibc-all-langpacks, dnf install glibc-langpack-mr
   locale -a|grep mr
   mr_IN

  Missing mr_IN.utf

I am not sure about usage of mr_IN.utf8, but this is more issue from backward compatibility side.

Steps to Reproduce:
1. Install glibc-langpack-mr
2. locale -a|grep mr

Actual results:
List only 
- mr_IN

Expected results:
As a backward compatibility, It should list both
mr_IN
mr_IN.alias

To be clear we should either have:

(a) Both mr_IN and mr_IN.utf8 with locale-archive and without.

or

(b) Only mr_IN with locale-archive adn without.

The real solution here is to create the symlinks in /usr/lib/locale that match exactly what the locale-archive is displaying.

Comment 1 Pravin Satpute 2019-05-03 07:34:17 UTC
Closing this as a duplicate of original issue.  https://bugzilla.redhat.com/show_bug.cgi?id=1326470
Updated the blocks field.

*** This bug has been marked as a duplicate of bug 1326470 ***


Note You need to log in before you can comment on or make changes to this bug.