Bug 1705659 - Overcloud deployment with composable roles fails with Initializing overcloud plan deployment '>' not supported between instances of 'str' and 'int'
Summary: Overcloud deployment with composable roles fails with Initializing overcloud ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: beta
: 15.0 (Stein)
Assignee: Michele Baldessari
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-02 17:03 UTC by Marius Cornea
Modified: 2019-11-12 10:07 UTC (History)
10 users (show)

Fixed In Version: openstack-tripleo-common-10.7.1-0.20190520133901.eeee6fb.el8ost.noarch
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:21:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1828305 0 None None None 2019-05-08 21:54:06 UTC
OpenStack gerrit 658151 0 'None' MERGED Make get_enabled_services() more robust 2020-10-09 12:10:56 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:21:56 UTC

Description Marius Cornea 2019-05-02 17:03:30 UTC
Description of problem:

Overcloud deployment with composable roles fails with Initializing overcloud plan deployment '>' not supported between instances of 'str' and 'int'

/var/log/containers/mistral/executor.log:

2019-05-02 04:58:01.962 9 ERROR tripleo_common.actions.container_images [req-28e3f868-8595-4bef-96d3-8e453c1e15d1 00a9a3ac3ac34f5da5cc75fc6723e6ae c37c1c5cde444df0935c8a17a1eae610 - default default] Error occurred while processing plan files.: TypeError: '>' not supported between instances of 'str' and 'int'
2019-05-02 04:58:01.962 9 ERROR tripleo_common.actions.container_images Traceback (most recent call last):
2019-05-02 04:58:01.962 9 ERROR tripleo_common.actions.container_images   File "/usr/lib/python3.6/site-packages/tripleo_common/actions/container_images.py", line 141, in run
2019-05-02 04:58:01.962 9 ERROR tripleo_common.actions.container_images     env, role_data, dry_run=True)
2019-05-02 04:58:01.962 9 ERROR tripleo_common.actions.container_images   File "/usr/lib/python3.6/site-packages/tripleo_common/image/kolla_builder.py", line 156, in container_images_prepare_multi
2019-05-02 04:58:01.962 9 ERROR tripleo_common.actions.container_images     service_filter = build_service_filter(environment, roles_data)
2019-05-02 04:58:01.962 9 ERROR tripleo_common.actions.container_images   File "/usr/lib/python3.6/site-packages/tripleo_common/image/kolla_builder.py", line 90, in build_service_filter
2019-05-02 04:58:01.962 9 ERROR tripleo_common.actions.container_images     enabled_services = get_enabled_services(environment, roles_data)
2019-05-02 04:58:01.962 9 ERROR tripleo_common.actions.container_images   File "/usr/lib/python3.6/site-packages/tripleo_common/image/kolla_builder.py", line 74, in get_enabled_services
2019-05-02 04:58:01.962 9 ERROR tripleo_common.actions.container_images     if count > 0:
2019-05-02 04:58:01.962 9 ERROR tripleo_common.actions.container_images TypeError: '>' not supported between instances of 'str' and 'int'
2019-05-02 04:58:01.962 9 ERROR tripleo_common.actions.container_images 


Version-Release number of selected component (if applicable):
python3-tripleo-common-10.7.1-0.20190423083511.2199eeb.el8ost.noarch
openstack-tripleo-common-10.7.1-0.20190423083511.2199eeb.el8ost.noarch
openstack-tripleo-common-containers-10.7.1-0.20190423083511.2199eeb.el8ost.noarc

How reproducible:
100%

Steps to Reproduce:
1. Deploy overcloud with ControllerOpenstack Database Messaging Networker CephStorage and Compute roles

openstack overcloud deploy \
  --timeout 100 \
  --templates /usr/share/openstack-tripleo-heat-templates \
  --libvirt-type kvm \
  --stack overcloud \
  -r /home/stack/composable_roles/roles/roles_data.yaml \
  -e /home/stack/composable_roles/roles/nodes.yaml \
-e /home/stack/composable_roles/internal.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml \
-e /home/stack/composable_roles/network/network-environment.yaml \
-e /home/stack/composable_roles/network/dvr-override.yaml \
-e /home/stack/composable_roles/enable-tls.yaml \
-e /home/stack/composable_roles/inject-trust-anchor.yaml \
-e /home/stack/composable_roles/public_vip.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/ssl/tls-endpoints-public-ip.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/ceph-ansible/ceph-ansible.yaml \
-e /home/stack/composable_roles/hostnames.yaml \
-e /home/stack/composable_roles/debug.yaml \
-e /home/stack/composable_roles/config_heat.yaml \
-e ~/containers-prepare-parameter.yaml \


Actual results:
Deployment fails 

Exception occured while running the command
Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/tripleoclient/command.py", line 30, in run
    super(Command, self).run(parsed_args)
  File "/usr/lib/python3.6/site-packages/osc_lib/command/command.py", line 41, in run
    return super(Command, self).run(parsed_args)
  File "/usr/lib/python3.6/site-packages/cliff/command.py", line 184, in run
    return_code = self.take_action(parsed_args) or 0
  File "/usr/lib/python3.6/site-packages/tripleoclient/v1/overcloud_deploy.py", line 919, in take_action
    self._deploy_tripleo_heat_templates_tmpdir(stack, parsed_args)
  File "/usr/lib/python3.6/site-packages/tripleoclient/v1/overcloud_deploy.py", line 374, in _deploy_tripleo_heat_templates_tmpdir
    new_tht_root, tht_root)
  File "/usr/lib/python3.6/site-packages/tripleoclient/v1/overcloud_deploy.py", line 477, in _deploy_tripleo_heat_templates
    deployment_options=deployment_options)
  File "/usr/lib/python3.6/site-packages/tripleoclient/v1/overcloud_deploy.py", line 494, in _try_overcloud_deploy_with_compat_yaml
    deployment_options=deployment_options)
  File "/usr/lib/python3.6/site-packages/tripleoclient/v1/overcloud_deploy.py", line 247, in _heat_deploy
    deployment_options=deployment_options)
  File "/usr/lib/python3.6/site-packages/tripleoclient/workflows/deployment.py", line 81, in deploy_and_wait
    deploy(log, clients, **workflow_input)
  File "/usr/lib/python3.6/site-packages/tripleoclient/workflows/deployment.py", line 63, in deploy
    % (payload['status'], wf_name))
ValueError: Unexpected status FAILED for tripleo.deployment.v1.deploy_plan
Unexpected status FAILED for tripleo.deployment.v1.deploy_plan
Removing the current plan files
Uploading new plan files
Plan updated.
Processing templates in the directory /tmp/tripleoclient-hiea77gh/tripleo-heat-templates
WARNING: Following parameter(s) are defined but not used in plan. Could be possible that parameter is valid but currently not used.
  CinderBackupBackend
  NeutronTunnelTypes
Deploying templates in the directory /tmp/tripleoclient-hiea77gh/tripleo-heat-templates
Initializing overcloud plan deployment
'>' not supported between instances of 'str' and 'int'


Expected results:
No failures

Additional info:
Attaching templates and logs

Comment 10 Artem Hrechanychenko 2019-05-23 13:31:16 UTC
VERIFIED

core_puddle: RHOS_TRUNK-15.0-RHEL-8-20190520.n.2
openstack-tripleo-common-10.7.1-0.20190520133901.eeee6fb.el8ost.noarch

Comment 13 errata-xmlrpc 2019-09-21 11:21:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.