Bug 170580 - Rename "Native Eclipse" to "Fedora Eclipse" on splashscreen
Rename "Native Eclipse" to "Fedora Eclipse" on splashscreen
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andrew Overholt
: FutureFeature
Depends On:
Blocks: 159880
  Show dependency treegraph
 
Reported: 2005-10-12 20:47 EDT by Anthony Green
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-06 15:47:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anthony Green 2005-10-12 20:47:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050909 Fedora/1.0.6-1.2.fc4 Firefox/1.0.6

Description of problem:
The current Eclipse splash says "NATIVE ECLIPSE"  and "based on Eclipse 3.1".

I've spoken to a number of people about this, and nobody seems to like the "NATIVE ECLIPSE" name.  It's also a bit misleading, since it's only "native" if you're using the java-gcj-compat alternative.  Can we please change this to "FEDORA ECLIPSE"?

Also, we're using 3.1.1 now, not 3.1.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start Eclipse
2.Look at the splash screen
3.
  

Additional info:
Comment 1 Andrew Overholt 2005-10-12 21:53:16 EDT
Billy:  do you think it's possible to make the splash screen dynamic?  ie. based
upon what JVM is running?  The work that's gone into the
progress-meter-on-splash-screen in 3.2 - does that alter the image itself or do
some sort of overlay in a window?
Comment 2 Billy Biggs 2005-10-12 22:14:15 EDT
The splash screen is the splash.bmp file in the
org.eclipse.platform plugin.  It seems that you can tell
eclipse where to look for a splash screen using the
osgi.splashLocation property, see the default config.ini in
the configuration directory.  So, I think that if you wanted
to have some logic in a shell script somewhere then this is
definitely possible.

The progress meter is simply a GtkProgressBar positioned on
top of the image.  Eclipse tells the launcher where to place
the progress bar and the label, so there may be some more
system properties or something that you could use to tweak where
the progress bar is on top of a different splash screen.

That all said, I personally think the name is misleading anyway
and you should just use "Fedora Eclipse" all the time. ;)
Comment 3 Andrew Overholt 2005-12-06 15:47:51 EST
Diana was kind enough to do up a new splash screen.  It'll appear in the next
builds in both FC4 updates-testing and rawhide.  It's in CVS now.
Comment 4 Ben Konrath 2006-01-04 14:44:58 EST
This is fixed in updates-testing with eclipse-platform-3.1.1-1jpp_1fc.FC4.11.

Note You need to log in before you can comment on or make changes to this bug.