Bug 170585 - Error: Package initscripts needs kernel < 2.6.12, this is not available
Error: Package initscripts needs kernel < 2.6.12, this is not available
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-12 23:47 EDT by Peter Ennis
Modified: 2014-01-21 17:52 EST (History)
1 user (show)

See Also:
Fixed In Version: FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-19 16:11:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Ennis 2005-10-12 23:47:40 EDT
Description of problem:

Running rawhide.
Did not yum for a while and I get complaints about
kernel version, so tried update of kernel.
Workarounds?
or
Wait?

[developer@lfs ~]$ sudo su -c 'yum update kernel'
Setting up Update Process
Setting up Repos
development               100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for kernel to pack into transaction set.
kernel-2.6.13-1.1601_FC5. 100% |=========================| 192 kB    00:05
---> Package kernel.i686 0:2.6.13-1.1601_FC5 set to be installed
--> Running transaction check
--> Processing Conflict: kernel conflicts isdn4k-utils < 3.2-32
--> Processing Conflict: kernel conflicts nfs-utils < 1.0.7-12
--> Processing Conflict: kernel conflicts ppp < 2.4.3-3
--> Processing Conflict: kernel conflicts procps < 3.2.5-6.3
--> Processing Conflict: kernel conflicts jfsutils < 1.1.7-2
--> Processing Conflict: kernel conflicts udev < 063-6
--> Processing Conflict: kernel conflicts e2fsprogs < 1.37-4
--> Processing Dependency: initscripts >= 8.11.1-1 for package: kernel
--> Processing Dependency: mkinitrd >= 4.2.21-1 for package: kernel
--> Processing Conflict: kernel conflicts iptables < 1.3.2-1
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package iptables.i386 0:1.3.2-1 set to be updated
---> Package procps.i386 0:3.2.5-7 set to be updated
---> Package jfsutils.i386 0:1.1.7-2 set to be updated
---> Package ppp.i386 0:2.4.3-4 set to be updated
---> Package isdn4k-utils.i386 0:3.2-32 set to be updated
---> Package nfs-utils.i386 0:1.0.7-18.FC5 set to be updated
---> Package e2fsprogs.i386 0:1.38-1 set to be updated
---> Package udev.i386 0:069-10 set to be updated
---> Package mkinitrd.i386 0:5.0.4-1 set to be updated
---> Package initscripts.i386 0:8.17-1 set to be updated
--> Running transaction check
--> Processing Dependency: e2fsprogs = 1.36 for package: e2fsprogs-devel
--> Processing Dependency: libpcap.so.0.9.3 for package: ppp
--> Processing Dependency: SysVinit >= 2.85-38 for package: initscripts
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: procps
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: ppp
--> Processing Dependency: libpcap.so.0.9.3 for package: isdn4k-utils
--> Processing Conflict: initscripts conflicts kernel < 2.6.12
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: udev
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: nfs-utils
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: mkinitrd
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: e2fsprogs
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: isdn4k-utils
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: initscripts
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package SysVinit.i386 0:2.85-40 set to be updated
---> Package libpcap.i386 14:0.9.3-3 set to be updated
---> Package e2fsprogs-devel.i386 0:1.38-1 set to be updated
---> Package glibc.i686 0:2.3.90-14 set to be updated
--> Running transaction check
--> Processing Conflict: initscripts conflicts kernel < 2.6.12
--> Processing Dependency: glibc-common = 2.3.90-14 for package: glibc
--> Processing Conflict: glibc-common conflicts glibc > 2.3.4
--> Processing Dependency: libpcap.so.0.8.3 for package: ethereal
--> Processing Dependency: glibc = 2.3.4 for package: glibc-headers
--> Processing Dependency: glibc = 2.3.4 for package: glibc-devel
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package glibc-common.i386 0:2.3.90-14 set to be updated
---> Package glibc-headers.i386 0:2.3.90-14 set to be updated
---> Package ethereal.i386 0:0.10.12-9 set to be updated
---> Package glibc-devel.i386 0:2.3.90-14 set to be updated
--> Running transaction check
--> Processing Conflict: initscripts conflicts kernel < 2.6.12
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
--> Running transaction check
--> Processing Conflict: initscripts conflicts kernel < 2.6.12
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
--> Running transaction check
Error: Unable to satisfy dependencies
Error: Package initscripts needs kernel < 2.6.12, this is not available.
[developer@lfs ~]$


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeremy Katz 2006-04-19 16:11:25 EDT
Fixed since

Note You need to log in before you can comment on or make changes to this bug.