This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 170586 - preview-latex is absent from yum's downloaded emacs-auctex-11.81-1.fc4.noarch.rpm
preview-latex is absent from yum's downloaded emacs-auctex-11.81-1.fc4.noarch...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: emacs-auctex (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ed Hill
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-13 00:47 EDT by P V
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 11.83 Rel 5.fc5; maybe earlier
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-23 09:34:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description P V 2005-10-13 00:47:51 EDT
Description of problem:
"As of AUCTeX 11.81, preview-latex should already be integrated into AUCTeX,
so no separate download will be necessary."

Indeed preview-latex is in the file
http://ftp.gnu.org/pub/gnu/auctex/auctex-11.81.tar.gz

but seems to be absent from yum's downloaded
/var/cache/yum/extras/packages/emacs-auctex-11.81-1.fc4.noarch.rpm
Comment 1 François Patte 2005-12-17 02:37:38 EST
This version of auctex returns: void-function TeX-defun if you want to load a
TeX file in emacs
Comment 2 Ed Hill 2005-12-20 15:08:40 EST
Hi "PV" and Francios, I had some trouble trying to create a specfile for 
emacs-auctex that would correctly install the preview-latex parts.  I've 
also been very busy lately.  So if you (or anyone else) can get preview-
latex to work within the existing specfile, then I'll gladly work with 
you to get it added to Fedora Extras.  But I don't have enough time right 
now to add it on my own.
Comment 3 Jonathan Underwood 2006-05-03 06:46:18 EDT
preview-latex functionality is now present in current RPM (11.82-8).
Comment 4 François Patte 2006-05-03 17:30:46 EDT
bug still there.....
Comment 5 Ed Hill 2006-05-03 17:56:07 EDT
Hi François, could you please be a little more descriptive of the problem?
The 11.82-8.fcX packages were only *just* added to the Extras repo, so are 
you certain that the problems still exists with the latest revision?  And, 
if there are still problems, could you please describe what they are?
Comment 6 François Patte 2006-05-04 06:56:25 EDT
(In reply to comment #5)
> Hi François, could you please be a little more descriptive of the problem?
> The 11.82-8.fcX packages were only *just* added to the Extras repo, so are 
> you certain that the problems still exists with the latest revision?  And, 
> if there are still problems, could you please describe what they are?

Emacs still returns: "void-function TeX-defun" if you load a latex file. 
Comment 7 Jonathan Underwood 2006-05-06 18:20:38 EDT
There's no function TeX-defun defined in AUCTeX. You must have something in your
.emacs file that is calling TeX-defun, which may have been present in a very old
version of AUCTeX. Can you try starting emacs with the -q command line switch
and load a latex file and see if the problem persists.
Comment 8 François Patte 2006-05-09 03:21:17 EDT
Yes, that's was the trick! My .emacs was reffering to an old lisp path due to
(not so) old Auctex installation before rpm distribution of this package.
Everything seems OK now. 
Comment 9 Jonathan Underwood 2006-06-23 08:45:31 EDT
Hi Ed, PV

This Bug is resolved - perhaps one of you could close it as fixed.

Thanks,
Jonathan
Comment 10 P V 2006-06-23 09:34:19 EDT
I believe this bug is resolved. 

> locate preview-latex
/usr/share/emacs/site-lisp/site-start.d/preview-latex.el
/usr/share/info/preview-latex.info.gz

Note You need to log in before you can comment on or make changes to this bug.