Bug 170586 - preview-latex is absent from yum's downloaded emacs-auctex-11.81-1.fc4.noarch.rpm
Summary: preview-latex is absent from yum's downloaded emacs-auctex-11.81-1.fc4.noarch...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: emacs-auctex   
(Show other bugs)
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ed Hill
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-10-13 04:47 UTC by P V
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version: 11.83 Rel 5.fc5; maybe earlier
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-23 13:34:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description P V 2005-10-13 04:47:51 UTC
Description of problem:
"As of AUCTeX 11.81, preview-latex should already be integrated into AUCTeX,
so no separate download will be necessary."

Indeed preview-latex is in the file
http://ftp.gnu.org/pub/gnu/auctex/auctex-11.81.tar.gz

but seems to be absent from yum's downloaded
/var/cache/yum/extras/packages/emacs-auctex-11.81-1.fc4.noarch.rpm

Comment 1 François Patte 2005-12-17 07:37:38 UTC
This version of auctex returns: void-function TeX-defun if you want to load a
TeX file in emacs

Comment 2 Ed Hill 2005-12-20 20:08:40 UTC
Hi "PV" and Francios, I had some trouble trying to create a specfile for 
emacs-auctex that would correctly install the preview-latex parts.  I've 
also been very busy lately.  So if you (or anyone else) can get preview-
latex to work within the existing specfile, then I'll gladly work with 
you to get it added to Fedora Extras.  But I don't have enough time right 
now to add it on my own.

Comment 3 Jonathan Underwood 2006-05-03 10:46:18 UTC
preview-latex functionality is now present in current RPM (11.82-8).

Comment 4 François Patte 2006-05-03 21:30:46 UTC
bug still there.....

Comment 5 Ed Hill 2006-05-03 21:56:07 UTC
Hi François, could you please be a little more descriptive of the problem?
The 11.82-8.fcX packages were only *just* added to the Extras repo, so are 
you certain that the problems still exists with the latest revision?  And, 
if there are still problems, could you please describe what they are?

Comment 6 François Patte 2006-05-04 10:56:25 UTC
(In reply to comment #5)
> Hi François, could you please be a little more descriptive of the problem?
> The 11.82-8.fcX packages were only *just* added to the Extras repo, so are 
> you certain that the problems still exists with the latest revision?  And, 
> if there are still problems, could you please describe what they are?

Emacs still returns: "void-function TeX-defun" if you load a latex file. 

Comment 7 Jonathan Underwood 2006-05-06 22:20:38 UTC
There's no function TeX-defun defined in AUCTeX. You must have something in your
.emacs file that is calling TeX-defun, which may have been present in a very old
version of AUCTeX. Can you try starting emacs with the -q command line switch
and load a latex file and see if the problem persists.

Comment 8 François Patte 2006-05-09 07:21:17 UTC
Yes, that's was the trick! My .emacs was reffering to an old lisp path due to
(not so) old Auctex installation before rpm distribution of this package.
Everything seems OK now. 

Comment 9 Jonathan Underwood 2006-06-23 12:45:31 UTC
Hi Ed, PV

This Bug is resolved - perhaps one of you could close it as fixed.

Thanks,
Jonathan

Comment 10 P V 2006-06-23 13:34:19 UTC
I believe this bug is resolved. 

> locate preview-latex
/usr/share/emacs/site-lisp/site-start.d/preview-latex.el
/usr/share/info/preview-latex.info.gz



Note You need to log in before you can comment on or make changes to this bug.