Bug 1705867 - log4j fails to install on i686 and armv7hl in Fedora 30 and rawhide
Summary: log4j fails to install on i686 and armv7hl in Fedora 30 and rawhide
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: log4j
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Stewardship SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F30FailsToInstall F31FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2019-05-03 04:51 UTC by Mattias Ellert
Modified: 2019-07-12 00:58 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-12 00:58:15 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Fedora Pagure stewardship-sig issue 13 None None None 2019-05-06 03:03:37 UTC

Description Mattias Ellert 2019-05-03 04:51:37 UTC
Description of problem:

log4j fails to install due to missing dependencies on i686 and armv7hl:

DEBUG util.py:439:  Last metadata expiration check: 0:00:00 ago on Fri May  3 04:28:56 2019.
DEBUG util.py:439:  Error: 
DEBUG util.py:439:   Problem: package log4j-2.11.1-3.fc30.noarch requires mvn(org.eclipse.persistence:javax.persistence), but none of the providers can be installed
DEBUG util.py:439:    - conflicting requests
DEBUG util.py:439:    - nothing provides mvn(org.eclipse.osgi:org.eclipse.osgi) needed by eclipselink-persistence-api-2.1.0-7.fc30.noarch
DEBUG util.py:577:  Child return code was: 1

This is a regression from Fedora 29 where the package is installable on all architectures.

Version-Release number of selected component (if applicable):

log4j-2.11.1-3.fc30.noarch 

How reproducible:

Always

Steps to Reproduce:
1. Try to install log4j on i686 or armv7hl 

Actual results:

Installation fails due to missing dependencies

Expected results:

Successful installation

Comment 2 Fabio Valentini 2019-06-29 12:45:40 UTC
I think this issue should be resolved on rawhide.

eclipselink-persistence-api now builds against osgi-core instead of the eclipse OSGi implementation.

Can you confirm that it's fixed on rawhide?
If so, maybe we should backport the eclipselink-persistence-api change to fedora 30.

Comment 3 Mattias Ellert 2019-06-30 06:41:25 UTC
mock --root fedora-rawhide-i386 --install log4j

succeeds

Comment 4 Mattias Ellert 2019-06-30 08:33:15 UTC
Merge to f30?

Comment 5 Fabio Valentini 2019-06-30 09:32:06 UTC
I'll prepare an update.

Comment 6 Fedora Update System 2019-06-30 09:47:13 UTC
FEDORA-2019-58643bccf7 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-58643bccf7

Comment 7 Fedora Update System 2019-07-01 01:42:55 UTC
eclipselink-persistence-api-2.1.0-8.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-58643bccf7

Comment 8 Fedora Update System 2019-07-12 00:58:15 UTC
eclipselink-persistence-api-2.1.0-8.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.