Bug 17059 - gcc/libstdc++ is broken with glibc 2.2.
Summary: gcc/libstdc++ is broken with glibc 2.2.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-29 00:47 UTC by Red Hat Bugzilla
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-30 04:23:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A libio compatibility patch for glibc. (2.58 KB, patch)
2000-08-29 17:03 UTC, Red Hat Bugzilla
no flags Details | Diff

Description Red Hat Bugzilla 2000-08-29 00:47:36 UTC
I have been trying to figure out why I have so many C++ failures 
with "make check" in gcc from CVS under RedHat 7.0 beta. It turned
out that the libio headers from libstdc++ in gcc are way out of date
comparing with glibc 2.2. There are so many fields added to libio
in glibc 2.2. As the result, libstdc++ is pretty much broken. Even
this simple program

#include <iostream>
main ()
{
  cout << "hello world\n";
}

won't print out anything when compiled under RedHat 7.0 beta. It
works fine under RedHat 6.2. Also there is no C++ binary compatibility
from RedHat 6.2 to 7.0 since libio has been changed so much and there
is no versioning provided for it. You can compile the simple code above
under RedHat 6.2 and run it under both 6.2/7.0.

BTW, I don't know if libio in libstdc++-b3 is in sync with glibc 2.2.


H.J.

Comment 1 Red Hat Bugzilla 2000-08-29 01:01:32 UTC
There is no binary compatibility issue, at least none I'm aware of.  The only
problem is compling C++ code.  The libstdc++-3 (not v3) headers are pretty much
borken but this is know.

I assumed that somebody took care of this since some program of the distribution
are written in C++.


Comment 2 Red Hat Bugzilla 2000-08-29 01:07:58 UTC
Try compile my simeple program under RedHat 6.2 and run it under
7.0 beta. Make sure compat-libstdc++-6.2-2.9.0.9 is installed under
7.0 beta. The problem may not be that bad. We just have to fix all
versions of shared libstdc++ to work with glibc 2.2.


Comment 3 Red Hat Bugzilla 2000-08-29 17:03:12 UTC
It turned it was a glibc bug. I am attaching a patch here. Ulrich, could
you please double check it. You can run "make check" for gcc from CVS.
Make sure you don't use libstdc++-v3.

Comment 4 Red Hat Bugzilla 2000-08-29 17:03:55 UTC
Created attachment 3081 [details]
A libio compatibility patch for glibc.

Comment 5 Red Hat Bugzilla 2000-08-30 04:23:40 UTC
Ulrich has checked in a fix into CVS. It will be nice to fix it in 7.0.

Comment 6 Red Hat Bugzilla 2000-09-01 10:26:43 UTC
Fixed in glibc-2.1.92-14


Note You need to log in before you can comment on or make changes to this bug.