Bug 170590 - pilot-link /usr/bin/install-datebook core dumps when syncing to Palm Tungsten E2
pilot-link /usr/bin/install-datebook core dumps when syncing to Palm Tungsten E2
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pilot-link (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-13 04:19 EDT by James Hunt
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-14 12:38:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
example of install-datebook input file that causes it to crash when syncing with Palm Tungsten E2 (45 bytes, text/plain)
2005-10-13 09:00 EDT, James Hunt
no flags Details

  None (edit)
Description James Hunt 2005-10-13 04:19:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
Running install-datebook crashes...

-------------------------------------
> install-datebook -r /tmp/birthdays.txt

   Listening for incoming connection on /dev/pilot... connected!

*** glibc detected *** install-datebook: realloc(): invalid pointer: 0x00124d1c ***
======= Backtrace: =========
/lib/obsolete/linuxthreads/i686/libc.so.6(__libc_realloc+0x32e)[0x178460]
/usr/local/lib/libpisock.so.9(pi_buffer_expect+0x58)[0xf745ad]
/usr/local/lib/libpisock.so.9(pack_Appointment+0xfe)[0xf5af6d]
install-datebook[0x80498f3]
/lib/obsolete/linuxthreads/i686/libc.so.6(__libc_start_main+0xab)[0x12625f]
install-datebook[0x804919d]
======= Memory map: ========
00111000-00234000 r-xp 00000000 fd:00 196662     /lib/obsolete/linuxthreads/i686/libc-2.3.5.so
00234000-00236000 r-xp 00123000 fd:00 196662     /lib/obsolete/linuxthreads/i686/libc-2.3.5.so
00236000-00238000 rwxp 00125000 fd:00 196662     /lib/obsolete/linuxthreads/i686/libc-2.3.5.so
00238000-0023a000 rwxp 00238000 00:00 0
00b1a000-00b1b000 r-xp 00b1a000 00:00 0          [vdso]
00f4f000-00f85000 r-xp 00000000 fd:05 1294470    /usr/local/lib/libpisock.so.9.0.0
00f85000-00f89000 rwxp 00036000 fd:05 1294470    /usr/local/lib/libpisock.so.9.0.0
08048000-0804d000 r-xp 00000000 fd:05 1294537    /usr/local/bin/install-datebook
0804d000-0804e000 rwxp 00004000 fd:05 1294537    /usr/local/bin/install-datebook
098b9000-098eb000 rwxp 098b9000 00:00 0          [heap]
41000000-4101a000 r-xp 00000000 fd:00 196683     /lib/ld-2.3.5.so
4101a000-4101b000 r-xp 00019000 fd:00 196683     /lib/ld-2.3.5.so
4101b000-4101c000 rwxp 0001a000 fd:00 196683     /lib/ld-2.3.5.so
413af000-413b8000 r-xp 00000000 fd:00 197605     /lib/libgcc_s-4.0.1-20050727.so.1
413b8000-413b9000 rwxp 00009000 fd:00 197605     /lib/libgcc_s-4.0.1-20050727.so.1
419e3000-419ea000 r-xp 00000000 fd:05 1264139    /usr/lib/libpopt.so.0.0.0
419ea000-419eb000 rwxp 00006000 fd:05 1264139    /usr/lib/libpopt.so.0.0.0
b7f74000-b7f75000 rw-p b7f74000 00:00 0
b7f94000-b7f96000 rw-p b7f94000 00:00 0
bff81000-bff96000 rw-p bff81000 00:00 0          [stack]
Abortado (core dumped)
> gdb install-datebook core.8079
GNU gdb Red Hat Linux (6.3.0.0-1.21rh)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...Using host libthread_db library "/lib/obsolete/linuxthreads/libthread_db.so.1".


warning: core file may not match specified executable file.
Reading symbols from shared object read from target memory...done.
Loaded system supplied DSO at 0xb1a000
Core was generated by `install-datebook -r /tmp/birthdays.txt'.
Program terminated with signal 6, Aborted.

warning: svr4_current_sos: Can't read pathname for load map: Input/output error

Reading symbols from /usr/lib/libpopt.so.0...done.
Loaded symbols for /usr/lib/libpopt.so.0
Reading symbols from /usr/local/lib/libpisock.so.9...done.
Loaded symbols for /usr/local/lib/libpisock.so.9
Reading symbols from /lib/obsolete/linuxthreads/i686/libc.so.6...done.
Loaded symbols for /lib/obsolete/linuxthreads/i686/libc.so.6
Reading symbols from /lib/ld-linux.so.2...done.
Loaded symbols for /lib/ld-linux.so.2
Reading symbols from /lib/libgcc_s.so.1...done.
Loaded symbols for /lib/libgcc_s.so.1
#0  0x0013a211 in kill () from /lib/obsolete/linuxthreads/i686/libc.so.6
(gdb) where
#0  0x0013a211 in kill () from /lib/obsolete/linuxthreads/i686/libc.so.6
#1  0x00139e81 in raise () from /lib/obsolete/linuxthreads/i686/libc.so.6
#2  0x0013b3f3 in abort () from /lib/obsolete/linuxthreads/i686/libc.so.6
#3  0x0016eb1e in __libc_message ()
   from /lib/obsolete/linuxthreads/i686/libc.so.6
#4  0x00178460 in realloc () from /lib/obsolete/linuxthreads/i686/libc.so.6
#5  0x00f745ad in pi_buffer_expect (buf=0x235ff4, expect=33) at pi-buffer.c:57
#6  0x00f5af6d in pack_Appointment (a=0xbff94564, buf=0x235ff4, 
    type=datebook_v1) at datebook.c:301
#7  0x080498f3 in main (argc=3, argv=0xbff947f4) at install-datebook.c:223
(gdb)

-------------------------------------
I've tried this with kernel 2.6.13-1.1526_FC4 and 2.6.12-1.1456_FC4 - same problem.

Looks like a real bug. I've tried setting "export MALLOC_CHECK_=0" prior to running install-datebook, but you still get a core dump.





Version-Release number of selected component (if applicable):
pilot-link-0.12.0-0.pre4.0.fc4.2 kernel-2.6.13-1.1526_FC4

How reproducible:
Always

Steps to Reproduce:
1. run, "/usr/bin/install-datebook -r <file>
  

Actual Results:  core dump.

Expected Results:  no core dump, and my Palm Tungsten E2 should have received the dates. It doesn't and eventually the sync operation on the palm times out.

Additional info:
Comment 1 Ngo Than 2005-10-13 07:57:04 EDT
i tried the above steps on my machine with Tungsten ET5, it works without 
any problem. Could you please attach the test file, which causes this problem? 
Thanks 
Comment 2 James Hunt 2005-10-13 09:00:06 EDT
Created attachment 119896 [details]
example of install-datebook input file that causes it to crash when syncing with Palm Tungsten E2

Here is an example input file. I believe the format is correct from reading the
manual page.

The attachment is a 1 line example that causes the crash, but my original file
of birthday dates (which is much bigger) has not changed for ages, and it
worked fine with my old Palm Zire (R.I.P.)
Comment 3 James Hunt 2005-10-13 10:44:30 EDT
I've just noticed what I thought might be the cause of this problem: I've got
the official fc4 pilot-link rpm installed, but I also have the *same* version of
pilot-link (that I compiled before the fc4 rpm was available) in /usr/local. The
clue was the backtrace showing:

/usr/local/lib/libpisock.so.9(pi_buffer_expect+0x58)[0xf745ad]
~~~~~~~~~~~~~~~
       ^
       |
    Should say /usr/lib/libpisock.so.9...

However, I've just removed my /usr/local version of pilot-link, and sure enough
the problem is still there.

Comment 4 James Hunt 2005-10-14 10:18:36 EDT
Additional info: the problem appears to be confined to install-datebook; I can
run 'pilot-xfer', and 'install-memo' with no problems.
Comment 5 James Hunt 2005-10-15 11:42:46 EDT
I've just downloaded and built pilot-link-0.11.7 from pilot-link.org using:

  ./configure --prefix=/usr/local && make && sudo make install

*That* version of 'install-datebook' works fine, so this is a regression in the
pilot-link package.
Comment 6 James Hunt 2005-10-18 03:35:56 EDT
Hi Ngo,

I've just noticed that this bug doesn't show up on my "Front Page" under, "Open
Issues: In Progress Reported by You". Is this a buglet with bugzilla?

Regards,

James.
Comment 7 Ngo Than 2006-04-14 12:38:16 EDT
i have already reverted to stable version 0.11.8, which is now available in
fc4-update-testing. You should please update (using yum) to this stable version.
Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.