Bug 1706075 - Missing obsolete for removed python2-langtable subpackage
Summary: Missing obsolete for removed python2-langtable subpackage
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-obsolete-packages
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F30FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2019-05-03 13:31 UTC by Mattias Ellert
Modified: 2019-06-28 21:53 UTC (History)
3 users (show)

Fixed In Version: fedora-obsolete-packages-30-44
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-26 04:06:58 UTC


Attachments (Terms of Use)

Description Mattias Ellert 2019-05-03 13:31:30 UTC
Description of problem:

Updating from langtable-0.0.41-2.fc30 to langtable-0.0.42-1.fc30 is broken due to missing obsolete for removed python2-langtable subpackage:

# dnf update *langtable*
Last metadata expiration check: 0:36:57 ago on Fri May  3 14:40:01 2019.
Dependencies resolved.

 Problem 1: package python2-langtable-0.0.41-2.fc30.noarch requires langtable = 0.0.41-2.fc30, but none of the providers can be installed
  - cannot install both langtable-0.0.42-1.fc30.noarch and langtable-0.0.41-2.fc30.noarch
  - cannot install both langtable-0.0.41-2.fc30.noarch and langtable-0.0.42-1.fc30.noarch
  - cannot install the best update candidate for package python2-langtable-0.0.41-2.fc30.noarch
  - cannot install the best update candidate for package langtable-0.0.41-2.fc30.noarch
 Problem 2: problem with installed package python2-langtable-0.0.41-2.fc30.noarch
  - package python2-langtable-0.0.41-2.fc30.noarch requires langtable-data = 0.0.41-2.fc30, but none of the providers can be installed
  - cannot install both langtable-data-0.0.42-1.fc30.noarch and langtable-data-0.0.41-2.fc30.noarch
  - cannot install both langtable-data-0.0.41-2.fc30.noarch and langtable-data-0.0.42-1.fc30.noarch
  - cannot install the best update candidate for package langtable-data-0.0.41-2.fc30.noarch
================================================================================
 Package               Architecture  Version               Repository      Size
================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 langtable             noarch        0.0.42-1.fc30         updates         35 k
 langtable-data        noarch        0.0.42-1.fc30         updates        1.1 M

Transaction Summary
================================================================================
Skip  2 Packages

Nothing to do.
Complete!


Version-Release number of selected component (if applicable):

python2-langtable-0.0.41-2.fc30

How reproducible:

Always

Steps to Reproduce:
1. Install python2-langtable on Fedora 30
2. Run "dnf update"

Actual results:

Update fails due to missing dependencies for installed version of python2-langtable

Expected results:

python2-langtable is obsoleted, so that the update succeed by removing it.

Comment 1 Fedora Update System 2019-06-24 22:08:17 UTC
FEDORA-2019-d623556847 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-d623556847

Comment 2 Fedora Update System 2019-06-25 02:11:29 UTC
fedora-obsolete-packages-30-44 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-d623556847

Comment 3 Fedora Update System 2019-06-26 04:06:58 UTC
fedora-obsolete-packages-30-44 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 4 Colin Barker 2019-06-28 21:53:16 UTC
Improved, however the following is still seen with x86_64
[root@copper ~]# uname -a
Linux xxxx.home 5.1.12-300.fc30.x86_64 #1 SMP Wed Jun 19 15:19:49 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
[root@xxxx ~]# dnf clean all
78 files removed
[root@xxxx ~]# dnf update
Adobe Systems Incorporated                                                                                                                                      4.5 kB/s | 1.9 kB     00:00    
Dropbox Repository                                                                                                                                              1.8 kB/s | 2.4 kB     00:01    
Fedora Modular 30 - x86_64                                                                                                                                      1.1 MB/s | 2.7 MB     00:02    
Steam                                                                                                                                                           8.3 kB/s | 3.9 kB     00:00    
Fedora Modular 30 - x86_64 - Updates                                                                                                                            847 kB/s | 2.2 MB     00:02    
Fedora 30 - x86_64 - Updates                                                                                                                                    2.0 MB/s |  15 MB     00:07    
Fedora 30 - x86_64                                                                                                                                              2.5 MB/s |  70 MB     00:28    
RPM Fusion for Fedora 30 - Free - Updates                                                                                                                       371 kB/s | 266 kB     00:00    
RPM Fusion for Fedora 30 - Free                                                                                                                                 622 kB/s | 735 kB     00:01    
RPM Fusion for Fedora 30 - Nonfree - Updates                                                                                                                    140 kB/s |  40 kB     00:00    
RPM Fusion for Fedora 30 - Nonfree                                                                                                                              512 kB/s | 227 kB     00:00    
Dependencies resolved.

 Problem 1: package yum-langpacks-0.4.5-10.fc30.noarch requires python2-langtable, but none of the providers can be installed
  - package fedora-obsolete-packages-30-44.noarch obsoletes python2-langtable < 0.0.43-3 provided by python2-langtable-0.0.41-2.fc30.noarch
  - cannot install the best update candidate for package yum-langpacks-0.4.5-10.fc30.noarch
  - cannot install the best update candidate for package fedora-obsolete-packages-30-43.noarch
 Problem 2: problem with installed package yum-langpacks-0.4.5-10.fc30.noarch
  - package yum-langpacks-0.4.5-10.fc30.noarch requires python2-langtable, but none of the providers can be installed
  - package fedora-obsolete-packages-30-44.noarch obsoletes python2-langtable < 0.0.43-3 provided by python2-langtable-0.0.41-2.fc30.noarch
  - cannot install the best update candidate for package python2-langtable-0.0.41-2.fc30.noarch
Nothing to do.
Complete!
[root@xxxx ~]# dnf upgrade --advisory=FEDORA-2019-d623556847
Last metadata expiration check: 0:03:33 ago on Fri 28 Jun 2019 22:46:00 BST.
Dependencies resolved.

 Problem: problem with installed package yum-langpacks-0.4.5-10.fc30.noarch
  - package yum-langpacks-0.4.5-10.fc30.noarch requires python2-langtable, but none of the providers can be installed
  - package fedora-obsolete-packages-30-44.noarch obsoletes python2-langtable < 0.0.43-3 provided by python2-langtable-0.0.41-2.fc30.noarch
  - cannot install the best update candidate for package fedora-obsolete-packages-30-43.noarch
Nothing to do.
Complete!
[root@xxxx ~]# dnf update
Last metadata expiration check: 0:03:43 ago on Fri 28 Jun 2019 22:46:00 BST.
Dependencies resolved.

 Problem 1: package yum-langpacks-0.4.5-10.fc30.noarch requires python2-langtable, but none of the providers can be installed
  - package fedora-obsolete-packages-30-44.noarch obsoletes python2-langtable < 0.0.43-3 provided by python2-langtable-0.0.41-2.fc30.noarch
  - cannot install the best update candidate for package yum-langpacks-0.4.5-10.fc30.noarch
  - cannot install the best update candidate for package fedora-obsolete-packages-30-43.noarch
 Problem 2: problem with installed package yum-langpacks-0.4.5-10.fc30.noarch
  - package yum-langpacks-0.4.5-10.fc30.noarch requires python2-langtable, but none of the providers can be installed
  - package fedora-obsolete-packages-30-44.noarch obsoletes python2-langtable < 0.0.43-3 provided by python2-langtable-0.0.41-2.fc30.noarch
  - cannot install the best update candidate for package python2-langtable-0.0.41-2.fc30.noarch
Nothing to do.
Complete!


Note You need to log in before you can comment on or make changes to this bug.