Bug 1706079 - boost-signals package dropped without being obsoleted
Summary: boost-signals package dropped without being obsoleted
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: boost
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jonathan Wakely
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-03 13:39 UTC by Mattias Ellert
Modified: 2019-05-16 00:51 UTC (History)
4 users (show)

Fixed In Version: boost-1.69.0-8.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-16 00:51:14 UTC


Attachments (Terms of Use)

Description Mattias Ellert 2019-05-03 13:39:48 UTC
Description of problem:

Updating to a recent boost version where the boost-signals package was dropped, leaves the old version of the package behind because there was no obsolete added for the removed subpackage.

Version-Release number of selected component (if applicable):

# rpm -q boost
boost-1.69.0-6.fc30.x86_64
# rpm -q boost-signals
boost-signals-1.66.0-14.fc29.x86_64

How reproducible:

Always

Steps to Reproduce:
1. Upgrade from Fedora 29 (boost 1.66) to Fedora 30 (boost 1.69)

Actual results:

The boost-signals-1.66.0 package is left on the system

Expected results:

The boost-signals-1.66.0 package is removed

Comment 1 Jonathan Wakely 2019-05-07 10:25:46 UTC
I'm testing a build with the main 'boost' package using:

Obsoletes: boost-signals%{?_isa} < 1.69.0

But this will only cause it to be removed if somebody installs the main 'boost' package. If you only install e.g. boost-system and boost-thread then you would still have the old boost-signals.

In practice this is not harmful, because libboost_signals.so.1.66.0 doesn't require any other boost libs and so doesn't block any upgrades or cause other problems. If we want to guarantee it's removed even when 'boost' isn't installed then it would ned to be added to the fedora-obsolete-packages RPM. I don't think we need to do that.

Comment 2 Miro Hrončok 2019-05-07 10:31:52 UTC
> But this will only cause it to be removed if somebody installs the main 'boost' package.

AFAIK this being in the repo will actually install boost to replace boost-signals on a regular update.


-----


fedora-obsolete-packages policy currently is: only remove packages that are problematic (when left on the system or blocking updates/upgrades).

Comment 3 Fedora Update System 2019-05-07 19:53:40 UTC
boost-1.69.0-7.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-36d7923120

Comment 4 Fedora Update System 2019-05-08 04:11:00 UTC
boost-1.69.0-7.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-36d7923120

Comment 5 Fedora Update System 2019-05-10 18:41:57 UTC
boost-1.69.0-8.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-36d7923120

Comment 6 Fedora Update System 2019-05-11 02:10:29 UTC
boost-1.69.0-8.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-36d7923120

Comment 7 Fedora Update System 2019-05-16 00:51:14 UTC
boost-1.69.0-8.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.