Bug 170609 - Firstboot forgets about reconfig mode if it times out
Firstboot forgets about reconfig mode if it times out
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: firstboot (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-13 08:33 EDT by Panu Matilainen
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2007-0307
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 18:49:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Panu Matilainen 2005-10-13 08:33:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.12) Gecko/20050921 Red Hat/1.0.7-1.4.1 Firefox/1.0.7

Description of problem:
If system set to start in reconfig mode (eg firstboot --reconfig from kickstart) but firstboot is left untouched long enough for it to timeout and continue booting, on the next reboot it starts in "normal" mode instead of reconfig.

Version-Release number of selected component (if applicable):
firstboot-1.3.39-2

How reproducible:
Always

Steps to Reproduce:
1. Install system with 'firstboot --reconfig' in kickstart 
2. Let the system boot up until firstboot and leave it there
3. After a while it times out and continues booting to login screen
4. Reboot and wait for firstboot to appear
  

Actual Results:  Firstboot comes up in the "normal" mode

Expected Results:  It should start again in the reconfig mode to allow setting root password etc which the "normal" firstboot mode doesn't allow.

Additional info:

Can be worked around by rebooting with 'reconfig' on the grub append line.
Actually it would be nice if it were possible to disable the timeout completely from eg /etc/sysconfig/firstboot because in this case I *know* it's not on serial console or anything, just a matter of install left to complete overnight or similar.
Comment 1 Chris Lumens 2006-03-23 15:26:14 EST
Would it be possible for you to test with FC5 and let me know if this issue
occurs for you there?  I've done a lot of work with firstboot and might have
these sorts of issues cleaned up now.
Comment 2 Bastien Nocera 2006-06-21 09:10:16 EDT
Lost event:
------- Additional Comments From clumens@redhat.com  2006-06-12 10:43 EST -------
Fixed in Rawhide, and will be in the next major release of RHEL.  If you
require this fix in an update release, please speak to your support representative
who will raise the issue through the proper channels.
--------
Comment 6 RHEL Product and Program Management 2006-09-05 15:48:52 EDT
The component this request has been filed against is not planned for inclusion
in the next update. The decision is based on weighting the priority and number
of requests for a component as well as the impact on the Red Hat Enterprise
Linux user-base: other components are considered having higher priority and the
number of changes we intend to include in update cycles is limited.
Comment 7 RHEL Product and Program Management 2006-09-05 16:01:55 EDT
Product Management has reviewed and declined this request.  You may appeal this
decision by reopening this request. 
Comment 16 Red Hat Bugzilla 2007-05-01 18:49:14 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0307.html

Note You need to log in before you can comment on or make changes to this bug.