Bug 170614 - missing buildrequirement for 32bit glibc-devel
Summary: missing buildrequirement for 32bit glibc-devel
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: memtest86+   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Warren Togami
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-10-13 13:02 UTC by Karsten Hopp
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-16 17:20:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log of failed build (1.33 KB, text/plain)
2005-10-13 13:02 UTC, Karsten Hopp
no flags Details

Description Karsten Hopp 2005-10-13 13:02:57 UTC
Description of problem:
missing a buildrequirement for 32bit glibc-devel:
gcc -c -m32 -march=i486 -fPIC -Wall -g -O2 -fno-strict-aliasing reloc.c
In file included from /usr/include/features.h:340,
                 from /usr/include/string.h:26,
                 from reloc.c:4:
/usr/include/gnu/stubs.h:7:27: error: gnu/stubs-32.h: No such file or directory
make: *** [reloc.o] Error 1
error: Bad exit status from /var/tmp/memtest86+-1.65-1.src.rpm/rpm-tmp.96357
(%build)


Version-Release number of selected component (if applicable):
memtest86+-1.65-1

How reproducible:
Always

Steps to Reproduce:
1.try to build package in a minimal environment (mock)
2.
3.
  

Additional info:

Comment 1 Karsten Hopp 2005-10-13 13:02:58 UTC
Created attachment 119897 [details]
log of failed build

Comment 2 Warren Togami 2005-10-13 21:07:50 UTC
glibc-devel >= 2.2.90-12 is needed by (installed) gcc-4.0.1-4.fc4.i386

http://fedoraproject.org/wiki/PackagingGuidelines
"There is no need to include the following packages or their dependencies as
BuildRequires because they would occur too often. These packages are considered
the minimum build environment."

Among the list is "gcc".  Install fedora-rpmdevtools to pull in all "assumed" deps.

Comment 3 Karsten Hopp 2005-10-14 12:41:10 UTC
You misunderstood...   
   
gcc pulls in the 64bit glibc-devel (on 64bit archs), but this bugreport is  
about needing the 32bit glibc-devel for /usr/include/gnu/stubs-32.h as well.   

Comment 4 Warren Togami 2005-10-14 19:05:01 UTC
Oh, multilib... hmm.  This is the result of the hack that jeremy added where the
32bit binary is built by the 64bit buildroot for no good reason.  AFAIK rpm has
no way of requiring a different arch of a given package name, although maybe it
would be appropriate to require the file directly.


Note You need to log in before you can comment on or make changes to this bug.