This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 17062 - PnP Interrupts don't appear in /proc/interrupts
PnP Interrupts don't appear in /proc/interrupts
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-28 21:13 EDT by John William
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-29 17:41:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John William 2000-08-28 21:13:14 EDT
Kernel 2.2.16. I have added an ISA PnP modem. It is configured 
as /dev/ttyS1 using IRQ3. However IRQ3 does not appear in /proc/interrupts.

Otherwise the device works fine.
Comment 1 Alan Cox 2000-08-29 17:41:51 EDT
Does it appear in /proc/interrupts while you have it open (eg while online) -if
so then its not a bug but a feature. Linux knows how to reuse the IRQ for other
things when not using that port.
Comment 2 John William 2000-08-31 21:40:20 EDT
Alan - you're right, it does appear in /proc/interrupts while the device is 
actually in use but not at other times.

I was confused because it doesn't appear in /etc/isapnp.gone either so unless 
the device is actually in use it's "assignment" to IRQ3 does not appear 
anywhere.

Note You need to log in before you can comment on or make changes to this bug.