Bug 170622 - yum checksums failing
yum checksums failing
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-13 09:41 EDT by James Greenwood
Modified: 2014-01-21 17:52 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-19 16:12:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Greenwood 2005-10-13 09:41:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
I keep on getting checksum errors with lots of different pakcages when I run yum update. Here is the error I get when this happens. Once the checksum fails it then fails to connect to other mirrors to try and download the file again.

NOTE: It is not just kdebase-3.4.2-0 that this happens with. It seem to happen randomly with different packages each time.

(1/236): kdebase-3.4.2-0. 100% |=========================|  27 MB    03:53
http://fedora.ngi.it/updates/4/x86_64/kdebase-3.4.2-0.fc4.1.x86_64.rpm: [Errno -1] Package does not match checksum
Trying other mirror.
http://ftp.chg.ru/pub/Linux/fedora/core/updates/4/x86_64/kdebase-3.4.2-0.fc4.1.x86_64.rpm: [Errno 4] IOError: HTTP Error 404: Date: Thu, 13 Oct 2005 13:28:59 GMT
Server: Apache/1.3.33 (Unix)
Transfer-Encoding: chunked
Content-Type: text/html; charset=iso-8859-1
Trying other mirror.
http://mirror.netglobalis.net/pub/fedora/core/updates/4/x86_64/kdebase-3.4.2-0.fc4.1.x86_64.rpm: [Errno 4] IOError: HTTP Error 404: Date: Thu, 13 Oct 2005 13:29:01 GMT
Server:
Content-Length: 330
Connection: close
Content-Type: text/html; charset=iso-8859-1
Trying other mirror.


Version-Release number of selected component (if applicable):
yum-2.4.0-0.fc4

How reproducible:
Always

Steps to Reproduce:
1.run the command yum update
2.
3.
  

Actual Results:  Get similar errors for other packages

Expected Results:  It downloads the package ok

Additional info:

This is a fresh install of FC4.
Comment 1 Jeremy Katz 2006-04-19 16:12:07 EDT
This should be better with the cachecookie stuff in later versions.

Note You need to log in before you can comment on or make changes to this bug.