Bug 170626 - Presenter unable to save
Presenter unable to save
Status: CLOSED DUPLICATE of bug 170618
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
n.a.
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-13 09:46 EDT by William Murray
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-13 09:50:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description William Murray 2005-10-13 09:46:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
When trying to a save a large file I occasionally get 'cannot save'
error which is unhelpful. I apologize that I cannot remember the precise words.
I have found empirically that 'export as ppt' sometimes works, and after a successful export as ppt I can even save os odp again. Or read in the ppt and proceed.
 Today, save as ppt crahed OO.

Version-Release number of selected component (if applicable):
openoffice.org-impress-1.9.125-1.1.0.fc4

How reproducible:
Sometimes

Steps to Reproduce:
1. Open large presentation
2.  Work on it for an hour
3.   Try to save it.
  

Actual Results:  'cannot save'
export to ppt --> crashed.

Expected Results:  Saved as odp. Or as ppt.

Additional info:

terminate called after throwing an instance of
'com::sun::star::lang::DisposedException'

---start copy and paste here---
0x95cb8a: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1db8a
0x95d3d8: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e3d8
0xec3420:  + 0x420 (__kernel_sigreturn + 0x0)
0x2f9888: /lib/libc.so.6 + 0x29888 (abort + 0xf8)
0x7afd5e: /usr/lib/libstdc++.so.6 + 0xb7d5e
(__gnu_cxx::__verbose_terminate_handler() + 0x16e)
0x7ada31: /usr/lib/libstdc++.so.6 + 0xb5a31
0x7ada66: /usr/lib/libstdc++.so.6 + 0xb5a66
0x7adb9a: /usr/lib/libstdc++.so.6 + 0xb5b9a (__cxa_rethrow + 0x0)
0xb3f8a0d8: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x2380d8
0xae017965: /usr/lib/openoffice.org2.0/program/libemp680li.so + 0x1c965
0xae0062c7: /usr/lib/openoffice.org2.0/program/libemp680li.so + 0xb2c7
0xae00a15f: /usr/lib/openoffice.org2.0/program/libemp680li.so + 0xf15f
0xae00a4dc: /usr/lib/openoffice.org2.0/program/libemp680li.so + 0xf4dc
(ExportPPT + 0x34)
0xb3f6f31f: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x21d31f
0xb3efa33f: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x1a833f
(sd::DrawDocShell::ConvertTo(SfxMedium&) + 0x20d)
0x681a17a: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x13017a
0x681a3af: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1303af
0x681a89b: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x13089b
0x681f33e: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x13533e
0x68424b5: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1584b5
0x6845b10: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x15bb10
(SfxBaseModel::storeAsURL(rtl::OUString const&,
com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue>
const&) + 0xc0)
0x6855d15: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x16bd15
0x6820cfc: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x136cfc
0x6822266: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x138266
0x68910ba: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1a70ba
0x68904a7: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1a64a7
0x6890998: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1a6998
(SfxDispatcher::_Execute(SfxShell&, SfxSlot const&, SfxRequest&,
unsigned short) + 0x138)
0x6899b8b: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1afb8b
0x6888451: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x19e451
0x6888869: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x19e869
0x5dfc3f1: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xb13f1
0x5dfc47c: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xb147c
0x58d9592: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x82592
0x59e8d42: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x191d42
(Menu::Select() + 0x3c)
0x59e37b5: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x18c7b5
0x59e37c8: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x18c7c8
0x58d9592: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x82592
0x5a2da47: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1d6a47
0x1262e72: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so +
0x1ee72
0x12880cd: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so +
0x440cd (SalDisplay::DispatchInternalEvent() + 0xad)
0xe509d3: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so +
0xa9d3
0x11e0730: /usr/lib/libglib-2.0.so.0 + 0x25730
0x11de4ce: /usr/lib/libglib-2.0.so.0 + 0x234ce (g_main_context_dispatch
+ 0x1dc)0x11e14d6: /usr/lib/libglib-2.0.so.0 + 0x264d6
0x11e19b8: /usr/lib/libglib-2.0.so.0 + 0x269b8 (g_main_context_iteration
+ 0x66)0xe505f9:
/usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0xa5f9
0x1289d99: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so +
0x45d99 (X11SalInstance::Yield(unsigned char) + 0x29)
0x58df8f4: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x888f4
(Application::Yield() + 0x50)
0x58df932: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x88932
(Application::Execute() + 0x26)
0x60f1254: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x29254
(desktop::Desktop::Main() + 0x149a)
0x58e4d21: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8dd21
(SVMain() + 0x45)
0x60ec307: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x24307
(sal_main + 0x47)
0x2e4d5f: /lib/libc.so.6 + 0x14d5f (__libc_start_main + 0xdf)
0x80484c5: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x4c5
---end copy and paste here---
Comment 1 Caolan McNamara 2005-10-13 09:50:50 EDT

*** This bug has been marked as a duplicate of 170618 ***

Note You need to log in before you can comment on or make changes to this bug.