Bug 1706295 - Fedora 29 firefox-65.0.1-1 All extensions disabled due to expiration of intermediate signing cert (Upstream bug)
Summary: Fedora 29 firefox-65.0.1-1 All extensions disabled due to expiration of inter...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1706311 1706353 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-04 05:28 UTC by Zamir SUN
Modified: 2019-05-10 03:26 UTC (History)
27 users (show)

Fixed In Version: firefox-66.0.4-1.fc30 firefox-66.0.4-1.fc28 firefox-66.0.4-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-07 16:46:35 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Mozilla Foundation 1548973 None None None 2019-06-11 08:46:41 UTC

Description Zamir SUN 2019-05-04 05:28:14 UTC
Description of problem:
Today I find almost all my extensions are disabled on my firefox-65.0.1-1.fc29.x86_64

And I saw this is an upstream bug reported on Mozilla already

https://bugzilla.mozilla.org/show_bug.cgi?id=1548973
All extensions disabled due to expiration of intermediate signing cert

I'm reporting it here in case future actions needed from Fedora packaging perspective.

Version-Release number of selected component (if applicable):
firefox-65.0.1-1.fc29.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Open firefox and check extensions
2. Click Legancy Extensions
3.

Actual results:
Most of my extensions are listed as could not be verified to use.

Expected results:


Additional info:

Comment 1 Piotr Drąg 2019-05-04 22:07:00 UTC
*** Bug 1706311 has been marked as a duplicate of this bug. ***

Comment 2 Piotr Drąg 2019-05-04 22:07:09 UTC
*** Bug 1706353 has been marked as a duplicate of this bug. ***

Comment 4 Zamir SUN 2019-05-05 07:01:56 UTC
(In reply to Gergely Gombos from comment #3)
> Fix file described here:
> https://blog.mozilla.org/addons/2019/05/04/update-regarding-add-ons-in-
> firefox/comment-page-6/#comment-226171

Thanks. This fixed the problem for me at the moment on another machine with firefox-66.0.2-1.fc29.x86_64.

Comment 5 Piotr Drąg 2019-05-05 12:35:01 UTC
I just got the studies that fixed the problem automatically enabled. I suppose it’s still not fixed for folks who don’t/won’t/can’t turn studies on.

Comment 6 Martin Stransky 2019-05-05 12:36:56 UTC
Mozilla releases 66.0.4 for it today, Fedora builds will follow.

Comment 7 Jan Pokorný [poki] 2019-05-06 12:13:37 UTC
Confirming that firefox-66.0.4-1.fc31.x86_64 fixed the problem for me
with Rawhide.  Thanks!

Comment 8 Fedora Update System 2019-05-07 07:41:59 UTC
firefox-66.0.4-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-af1c0225dc

Comment 9 Fedora Update System 2019-05-07 07:42:05 UTC
firefox-66.0.4-1.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-01202e494c

Comment 10 Fedora Update System 2019-05-07 07:42:10 UTC
firefox-66.0.4-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-726a479fbd

Comment 11 Dennixx 2019-05-07 09:52:24 UTC
What about updates for RHEL? I have the same issues in both RHEL6 and RHEL7...

Comment 12 Martin Stransky 2019-05-07 09:58:25 UTC
RHEL uses a different tracker, see https://bugzilla.redhat.com/show_bug.cgi?id=1707313

Comment 13 Fedora Update System 2019-05-07 16:46:35 UTC
firefox-66.0.4-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2019-05-08 01:18:45 UTC
firefox-66.0.4-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2019-05-08 03:04:43 UTC
firefox-66.0.4-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.